Brave failed to run, deleted profile, and reverted to old settings

I routinely close down my browser (completely close the application) and then start it again hours later (from the start menu). When I did that today, no browser window appeared. I tried starting it again, still no browser window. I ran Task Manager and saw two instances of Brave running using no CPU and little RAM. Associated with one (?) of these processes was a Brave installer, also using no CPU and little RAM. I observed this for some time and noticed to changes - it seemed like things were wedged. So I killed the processes.

When I restarted Brave, 2 out of 3 profiles that I’d created were absent (there was no profile icon on the toolbar). Somehow (I don’t remember how - maybe from opening it from history?) I opened a page that I generally viewed in a different profile and the browser found an older version of that profile and opened the page in that profile. At which point the profile button appeared on the browser toolbar (in both profiles) - BUT, the image associated with the second profile was an old image, from and earlier version of the profile. And I still could not access the third profile. There seems to be no record of it.


  1. Create 3 different profiles and set the option to “Continue where you left off” on startup
  2. Open 5 windows in each profile
  3. Close Brave
  4. Wait 1 minute (make sure Brave has fully shut down)
  5. Re-open Brave when it thinks it needs to install an update?
  6. No browser window appears, processes seem wedged.
  7. Kill processes.
  8. Re-open Brave
  9. Only the primary profile opens (w/ those pages that had been open when it had most recently been shut down)
  10. Look through history, find a page that was open in a different profile, open it.
  11. Second profile appears (and all pages that had previously been open in that profile are also automatically re-loaded?)

I’m guessing it was me killing the install process that screwed things up.

Expected result:

  1. Brave loads properly.
  2. Brave does not revert to an early version of settings when the setup process is killed (including losing a profile and newer profile settings).

Brave Version( check About Brave):
It’s currently “Version 1.16.68 Chromium: 86.0.4240.111 (Official Build) (64-bit)” but it’s updated itself once since I encountered my problem.

Additional Information:

Sometimes Chrome and Firefox also does this weird stuff.

Could you try opening Brave as an administrator?

I haven’t tried opening as an admin, but… I went to create a third profile again, gave it the same name as last time, and poof, all the windows and tabs that had been open in that profile when I last shut down Brave were re-opened. So it found the old profile. The icon associated with the profile on the toolbar was an old one, but when I went into the profile settings to change the icon, the CORRECT (newer) icon was actually already selected. I had to select a different icon and then re-select the newer icon to get it to take. Interesting!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.