Brave.exe Not responding Thread windows 10 (OleMainThreadWndName) possible memory leak

windows
crash
performance
bug
video

#1

Hi I have an issue where while using Brave my Windows 10 Version 10.0.17134 Build 17134 Processor Intel® Core™ i7-7700K CPU @ 4.20GHz, 4200 Mhz, 4 Core(s), 8 Logical Processor(s)Installed Physical Memory (RAM) 32.0 GB

My pc starts to experience odd stutters visual artifacts while watching videos, mainly noticeable while watching something on brave. I have a shortcut I created to taskkill any “Not Responding” program thread with single rightclick on desktop background, so if taskmgr does not see what is causing an unknown issue, I have a chance to recover system. So I noticed that I am getting these “Not Responding” programs that are able to be taskkilled, and before I taskkill I run a Tasklist /V >outputdatetime.txt command in command prompt to record whats going on since taskmgr does not admit anything is wrong… I have discovered Brave.exe is the culprit even though Taskmgr itself is not seeing anything wrong.
Example one Brave.exe out of anywhere from 10-40 Threads shows following.
brave.exe 12140 Console 1 17,456 K Not Responding VISION\plasm 0:00:00 OleMainThreadWndName

If I wait 10 minutes like I did for typing this up, I confirm possible memory leak with this issue.
brave.exe 12140 Console 1 225,600 K Not Responding VISION\plasm 0:00:00 OleMainThreadWndName
I showing “Brave is up to date
Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)”

Reboots or restarting brave does not help.

I did create .DMP file for this Brave.exe Thread (200MB Dmp file)
I reviewed with WinDbg Preview,
image image
Under Stack each Frame Index either gives Value of “The Scope Specified was not found” Or “The Parameter is incorrect”
No breakpoints showing in dump file.

If I taskkill the hung Brave.exe Thread, Brave itself and Tabs I have up remain up and performance improves, it only helps a few minutes at a time before issue returns. (I do confirm affected PID Thread does truly close when I do this) and Pid that opens up again a few minutes later is not same PID.

Any Help would be greatly appreciated.


#2

Little more information, I was able to use a program called Process Hacker (Basically an advanced Taskmgr) to get more details of the Brave.exe Thread that keeps going into “Not Responding” The command line showing is
“C:\Users\plasm\AppData\Local\BraveSoftware\Brave-Browser\Application\brave.exe” --type=utility --field-trial-handle=1564,15269445387302505087,7221009158343272181,131072 --enable-features=DesktopPWAWindowing,EnableEmojiContextMenu,NewExtensionUpdaterService,fill-on-account-select --disable-features=AutofillSaveCardSignInAfterLocalSave,AutofillServerCommunication,DefaultEnableOopRasterization,SharedArrayBuffer,UnifiedConsent,VizDisplayCompositor --lang=en-US --service-sandbox-type=audio --service-request-channel-token=7937936349340481741 --mojo-platform-channel-handle=16112 --ignored=" --type=renderer " /prefetch:8


#3

Just checking if anyone has any update even brief, I know these things sometimes take time. Issue still happening, latest tasklist is showing
brave.exe 248 Console 1 9,324 K Not Responding VISION\plasm 0:00:06 OleMainThreadWndName
I would like to continue to be able to use Brave if possible. thanks.


#4

@Plasmaburndeath,
Have you tried disabling hardware acceleration in Brave? This has been known to cause display issues similar to the ones you’re describing.
Settings --> Advanced --> System --> Hardware Acceleration


#5

Thank you @Mattches
It was on

I did not realize this was possible cause of this symptom since it was just same thread each time.-- I will turn this off restart brave and see if things improve and report back in the next day or two.
Is there a way in future for Brave to do a check for this and suggest turning it off?
For example on windows front background check through command prompt would be
tasklist /v /fi “Status Eq NOT RESPONDING” /fi “imagename eq brave.exe”

Which then will give either null output or following output

Image Name PID Session Name Session# Mem Usage Status User Name CPU Time Window Title
========================= ======== ================ =========== ============ =============== ================================================== ============ ========================================================================
brave.exe 248 Console 1 9,412 K Not Responding System_name\user_name 0:00:07 OleMainThreadWndName

and one could build null or not null outputs, for not null, it could trigger

msg * Minor Brave Performance issue detected - Please Try the following Go to Settings > Advanced > System > Hardware Acceleration > and Disable this by moving silder to the left Then Please save all work and restart Brave Browser when possible Thank you Ref error OleMainThreadWndName not responding

image


closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.