Brave doesn't launch


#1

Description of the issue: Updated to the latest version of brave Thursday and everything seemed to work fine. Bookmark scrolling is restored! Thanks! (Ok, I still have issues with the bookmark manager - but I know that’s being worked on.)

Anyway, my computer rebooted and now when I try to start Brave, I get a brief pause and then … nothing happens. I return to my desktop, lather, rinse, repeat. I am running Windows 10 Pro on a Surface Pro (ver 1803, build 17134.167) I am not sure what version of Brave is installed, but it was the newest release and the bookmark scrolling now works.

Steps to Reproduce (add as many as necessary):

  1. Rebooted, and problem persists.
  2. After attempting to launch brave, I get a brief blank screen - then return to my desktop. I can do this as many times as i want. when i open the task manager, it says there are no applications running.
  3. I’m not able to get a screen shot.

    Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often: Every time i try to start the program. I’ve attempted to update windows, but that had no effect. I’m not sure if there is a way to remove and reinstall brave.

Brave Version(about:brave): Can’t get to about:brave, program doesn’t launch. but i’m pretty sure it’s the most recent release.

Reproducible on current live release (yes/no): Yes (i think)

Additional Information: The browser was working fine. Then it stopped. Nothing seemed to have happened. It just stopped. Rebooting has had no effect.


#2

HI @fretless,

Thanks for reporting. :slight_smile:

  • Can you see Brave process running in Task Manager?

Thank you,
:slight_smile:


#3

yes. now that I’ve looked … there are 10 lines. all except one say 0% CPU. the other says 33.6% +/- a few tenths of a percent.

I can’t seem to get a screenshot.


#4

next best thing to a screen shot!


#5

then … after a VERY long wait, it did this:


#6

Well, Right Now, What I can help you with is : https://www.cnet.com/how-to/7-ways-to-take-screenshots-in-windows-10/

Would surely be helpful in future :wink:


#7

Ok, my symptoms have changed a little bit. I don’t think I did anything different, but now I get a blank page that hangs. It looks like this: (thanks Bob.)

!

BTW, the “Brave is not responding” dialog does not appear unless I hit the windows key or CNTL. otherwise all I get is a blank page to stare at.

When I go into the task manager, I do see Brave as an app. That wasn’t the case before. I have no idea what changed. But here’s what the TM looks like:


#8


#9

cc @sriram and @Mattches for additional assistance. :sweat_smile:


#10

Hello @fretless !
Could you post your about:brave data ? (Just type “about:brave” in the URL bar & you’d see a bunch of info about browser. Copy & Paste that here)
Also, What are the specs of the system you’re using (i.e. ram, CPU…etc)

Regards :smile:

P.S if nothing works:

You might wanna try giving fresh install a chance. Delete all the brave data. Firstly, Clear all the inBrowser data including history, cached data, cookies, formfill data & everything else from the ‘beginning of the time’
Now Uninstall brave (including Brave folders, Temporary folders from C:\ [as I can see you’re on W10 OS] and you might as well clear the data from program files & from c:\ (username)\roaming\brave. This description looks bizarre but trust me it’s an easy 60 second job)

Feel free to ping back on the community :sunny:


#11

@fretless In case you are not able to launch about:brave and check version you can just type this in run window %userprofile%\appdata\local\brave . This will contain a folder like app-0.xx.xx that would be the version installed. If after launch the browser doesn’t freeze (like in your screenshots) try deleting browser cache and then relaunch and check if it works fine.

You can follow the steps mentioned by @BOB-vagene but instead of clearing the profile folder I would suggest you rename the profile folder to brave.old and then launch a new window which will create a new profile.


#12

I’m unable to do about:brave, as the browser does not function - it partially loads, then hangs.

I can try the reinstall later today - - gotta go to work. :wink:


#13

thank you very much.

I’ll try this as soon as I can and let you know.


#14


#15

I’m not sure what you mean by clearing all the inBrowser data – I am unable to get the browser to launch. How do I clear cache, ect?

Thank you very much for the help.


#16


#17

Just wipe out the folders related to brave on your PC. Make sure there are no leftovers :gun: :heavy_check_mark:

  1. Jul 2018 07:12 by brave@discoursemail.com:

#18

Also, just to be on a safer side ; run a second opinion malware scanner to make sure your PC is clean. sometimes rootkits restrict applications that connects to the internet (I’m a malware analyst)

Since you’re using W10 OS, I suppose Emsisoft emergency Kit would be an optimal choice for you. Just download it & run it (make sure to enable PUP detections)

Sophos Virus Removal Tool is another great piece of software that exempted in my malware tests. You might wanna give it a try if not emsisoft.

AVG Free has improved a lot over the recent years (especially since Avast Softwares Pvt Ltd acquired it)

I have the options, the choice is yours :smile:

Here are the links of Emsisoft, Sophos & AVG respectively (All are freeware) :

https://www.emsisoft.com/en/software/eek/download

https://www.sophos.com/en-us/products/free-tools/virus-removal-tool.aspx

https://download.cnet.com/AVG-AntiVirus-Free/3000-2239_4-10320142.html?subj=es&lang=en

P.S You can totally ignored this response. This procedure is just to make sure a malware isn’t affecting your system & brave. As I said in bold, Just to be on a safer side

Best Regards !! :smile:


#19

ok, I used the emsisoft scan, found nothing.

I’ve tried uninstalling/reinstalling and the problem persists. I am not sure I was able to delete everything though. Windows 10 seems to hide a lot. I can’t even find the Brave folders.

Can you give me more specific instructions for deleting “all the brave data”?


#20

I tried uninstall/reinstall again. Now it seems to be back to where the browser never comes up at all. I do see instances of Brave in my processes.