Brave doesn't always open embedded twitch.tv clips in fullscreen correctly

  1. Launch Brave
  2. Visit Reddit for twitch clips like /r/Livestreamfail
  3. Click a post
  4. Play the clip
  5. Fullscreen and unfullscreen the clip until the fullscreen button / the whole navigation bar becomes unclickable.

When you fullscreen the clip sometimes it doesn’t allow you to go out of fullscreen / pause it because the control buttons become unclickable. Or sometimes the whole bottom bar disappears. You have to press ESC to get out of fullscreen and hope that the bottom bar will work next time you fullscreen the clip. I tried it with and without brave shield and both gave the same results.

@MPGod42,
To confirm, are you playing the clip embedded within Reddit? Or are you navigating away from the subreddit and viewing the content full screen on Twitch directly?

Within reddit, yes. I just open the post and play it on reddit.

@MPGod42,
So I’m not seeing this behavior on my end. Embedded videos on Reddit seem to play as intended. Can I ask what you have your Shields settings configured to for Reddit?

I’m seeing this happen with and without brave shield. And in incognito.

@MPGod42,
Can you try disabling Hardware Acceleration to test and see if this is the root of the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

yea i think that fixed it, thanks

@MPGod42,
Glad to hear that worked out. Thank you for your patience :slight_smile: