Brave does not seem to support Re-capcha and coinhive monero mining


#1

Hi, I just tried to submit a help ticket to minergate.com
The button which asks me to prove I am not a robot is not clickable in Brave Browser, although it works properly in Firefox.

Also I cannot have my web site visitors click on coinhive mining using Brave. It works with all other browsers. I do hope this is an unintentional bug. Because if it isn’t, you should not be dictating what I can and cannot present on my own website to my visitors. I am a very small content provider, and I’d be lucky to get a dozen visitors. Anything I can do to have them click through is a blessing for me. joenobel.com

Regards,
Joe


#2

Hi @JoeM,

Did you have Site isolation enabled in Preferences > Security? Having that setting enabled may cause an issue with reCaptcha. :slight_smile:

I believe that’s because Brave block coin mining by default.

You may want to become a Brave Publishers and ask you visitors to donate BAT through Brave Payments.

Thank you,
:slight_smile:


#3

1.) Thank you, I did have site isolation turned on. I turned it off.

  2.) I already am a brave publisher. I just don't think it should be up to Brave as to what I may present and what my well-informed visitors may click on. As your project is enlightened on one hand, you are Orwellian with the other. It's not for Brave or any other browser to pick and chose, i.e. censor me.

#4

As a user, I don’t want to be forced to browser mine for you. I’d much prefer to have coin mining off by default but a popup asking if I want to allow it.

I even installed an anti-js miner in chrome to prevent it.