Brave does not save extension permission

Using Macos 10.13.6 and also occurs on MacOS 11.1
Brave Version 1.19.86 on both
I get this permission ask every time I attempt to use this Share Link via Email extension in Brave.
https://www.dropbox.com/s/3oa3uk1lx0bwi9d/image1.png?dl=0 I check the box every time and it still asks me when I click the extension icon in Brave. Is there something in my settings preventing this from saving? It happens no matter who my default email client is. This is the extension in question https://chrome.google.com/webstore/detail/share-link-via-email/ejdbkikfbnnhmachnnomjfgjbgkcnjkb?hl=en-GB
Thanks

@Mattches Could there be something in my settings that fixes this or this a bug?

@752bfc1c933407ba6a19,
I know you said it doesn’t seem to make a difference, but what email client would you like to be using and is it an installed app(ie “Thunderbird” or “Mail” app on macOS)?

Airmail is my default and preferred email. I’ve also tried it with Canary mail too and I just tested it with the Apple default Mail App. Same behavior no matter which email client I use or which MacOS system I use.

@752bfc1c933407ba6a19,
I’m seeing the same behavior in Brave as well. Tbh I’m not entirely sure why – other extensions will show this same prompt and respect the checkbox but not this one. I tested on Chrome and the extension works fine so it is likely Brave related. Unfortunately it’s unlikely that a fix would come from our end – its more likely that the author of the extension will have to make adjustments to the extension. I’ve reached out to the team to see if there’s anything else I’m missing or that you can try.

Thank you! I really appreciate it. I’ll see if I can find out anything from the developer.

1 Like

Please report back. I found 3 other extensions that do the same thing (send emails by link) and none of them save permissions. They are:
Mailto: https://chrome.google.com/webstore/detail/mailto/gppbppehiogfokmpligejhaepeopajdf?hl=en-US
Send URL: https://chrome.google.com/webstore/detail/send-url/fmanefafgomooabofffoidipbfdbjilh?hl=en-US
I forgot the other. Something to do with Brave opening an outside/email app?

@752bfc1c933407ba6a19,
What is the default email you have set on your system? Also, can I see what you have added (if anything) email handlers to the browser in brave://settings/handlers?

I tried with Airmail and default Apple mail app. Here is the requested page. I don’t see anything there. Maybe it’s supposed to be this way? https://www.dropbox.com/s/xna6q7j35vnahyb/4.png?dl=0

@752bfc1c933407ba6a19,
And did you set Airmail/Mail (app) to be the default mail application on your system?

Yes. It opens as my default everywhere on MacOS.

Any update from the development team on this?