Brave does not retain login info and password once close

Description of the issue: Long story short, I have been using Brave on my devices and it worked quite well, until I had to sync the browser I am currently using with data from another device.
That worked, apparently, but all the new data (passwords, logins, etc.) is deleted every time I close the browser, which is incredibly annoying.

I do not have any “clear stuff on exit” setting turned on, and I left the Sync chain although that did not help.
I also tried importing login data from a local file (useful), and while that works, those data are deleted on browser closure, too.

Thank you in advance for your help.

Steps to Reproduce (add as many as necessary): 1. 2. 3. Close the browser and reopen?

Actual Result (gifs and screenshots are welcome!): All login data, etc. before I used Sync are gone.

Expected result: Data should be retained.

Reproduces how often: Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.58.137 Chromium: 117.0.5938.153 (Official Build) (64-bit) on Ubuntu 22.04 LST

Additional Information: Additionally, I am logged out from all websites when the browser is closed.

Not that I don’t trust you, but just want to have you double check and verify to make sure something didn’t somehow get activated. Especially since there are two different locations that primarily can do this.

  • brave://settings/clearBrowserDataOn Exit
    image

  • brave://settings/cookies

image

So it’s not related to sync? I know originally you mentioned that it was working well until you synced with your other device. But you’re saying even when not on a sync chain, it’s losing information?

Just to confirm, this issue is only occurring on one of your devices…the Ubuntu 22.04, right?

This is making it seem like something is clearing cookies and all on exit. If it’s not in Brave’s settings, then one would question if you have an extension doing it or if you might have a 3rd party program like Avast Cleaner, CCleaner, or something of the sort which might be doing it for you.

Only the new passwords? It keeps all the old passwords?

1 Like

I checked again, and neither option is turned on.

The problem started happening when I used sync, but I left the chain and it still happens, yes.

Yes, although my only other device to check is an Android phone since the other is currently broken for unrelated issues.

Exactly, that’s the strange part.
I thought something was just nuking everything on exit, but there is a handful of passwords that were saved on the browser before Sync, and those are retained normally, so I’m puzzled.

P.S.: I do not have CCleaner-type software either, not even sure they exist at all on Ubuntu.

1 Like

@Mattches seems weird to me. You have any thoughts?

1 Like

As a side note, uninstalling Brave and reinstalling it did nothing.

@xoxoxo1,
Can you check and see if Brave has access to your Keyring?

1 Like

Sure, if you tell me how to do that.

@xoxoxo1,
Open the Passwords and Keys app on your system, click Login and check for Brave Safe Storage (I believe that is how it will be shown here).

1 Like

There is no such entry, however (besides some non-Brave related ones) there are two nondescript entries at the top of the list, like this:

One has no information about it, the other lists snap.brave as app_id, so it might be related to this problem.

Note that in both cases, when I click on the “show password” key, it displays a bunch of gibberish such as v�k?"6�1��TbSb���, no idea whether that’s intended behavior or not.

Update: I deleted both nameless entries, nothing changed.

Another update: I uninstalled Brave, reinstalled it and tried logging into one random site then saving the password, without using sync or importing/changing anything.

Upon restarting the browser, saved password has been deleted and I have been logged out despite no options for that being active.

Mystery (mostly) solved: apparently the Snap version of Brave (provided through Ubuntu Software, etc.) is bugged, because when I removed it and installed Brave through apt-get, the problem finally vanished.

1 Like

Thank you so much for the updates and testing. I was wondering if snap had anything to do with it but some keyring shenanigans sounded more likely. I’m glad you were able to get this issue resolved and I will see what we can do to notify and resolve the issue with snap so that other users don’t run into this.

Thank you.

1 Like

Hi, great contributions…
This is to add to this discussion because I’ve been experiencing a similar situation… No matter what I do on my android device, anytime I use the brave Browser, either normally, or via Tor onion browsing, all data clears on exist, either almost immediately, or after few minutes.

Why I didn’t bother much was because I am more concerned about privacy. Although, it appears there is something truly clearing all data, including browsers and cookies…

This happens even upon adjusting my settings for some websites…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.