Brave does not recognize an open AP

I travel to RV parks around the country full time and occasionally I run into an AP that has a sign in requirement. That is, my USB adapter picks up an AP, I connect to it because it’s open, then I open Brave and search for the ‘Front Porch’ which is the RV parks Welcome page. I have to sign in there before I can browser the internet. These types of APs come in different flavors and the one I ran into here where I am staying in Idaho is rather simple. The AP is open (doesn’t require a password) but they don’t have a front porch. So I open Brave and type in Google.com in the address bar. Nothing happens. Tried several different URLs to no avail.

So after 30 minutes of trying to figure out how to connect the internet, I switch to Firefox. Type in google.com and an action bar pops up under the address bar that says I need to sign in to this AP. I click OK and up pops the RV park’s sign-in page. I sign in, and afterwards I can switch back to Brave and navigate the internet.

My question is, is there a setting that would cause Brave to open on sites like this so I can sign in? Or am I always going to have to remember to switch to Firefox or Chrome to do so? I would like to get rid of those other browsers eventually too.

Thanks!

@Jim_HiTek,
Thanks for reaching out.
You shouldn’t have to use another browser for this – I myself was just on a bit of a road trip and had to sign into different Wifi services in this way as well. However, I was always able to prompt Brave to display the “sign-in” window.

A couple things to check:

  1. When you first launch Brave and type in google.com (for example), try disabling Shields if it fails and try again – more specifically, try disabling the HTTPSE setting and try to reload the page. If this doesn’t work in your Shields panel, you should try disabling it in the Default Shields settings (Menu --> Settings --> Shields).
  2. Navigate to Menu --> Settings --> Addt'l settings --> Privacy/Security --> Site Settings --> USB devices and ensure that this option is set to Ask rather than to Block.

#2 doesn’t apply since my setup is set to Ask already.

I’ll try #1 the next time it happens. Which will likely be tomorrow because the AP here resets periodically.

Thanks for the guidance.