Brave does not play trailers on Amazon

bug

#1

Brave 1.0.43
Android 5.02

Hi,

there seems to be a bug with viewing movie trailers on amazon.com (or more specifically amazon.de). Playing a trailer is no longer possible because of an error regarding protected contents. Please see attached screenshot for the specific error message.

What have I tried so far:

  1. Deleting all Amazon related website information and cookies.
  2. Shields are off.
  3. Followed the specific advice given in the error message display (see screenshot).

Did it work on another browser?
Yes, Chrome plays trailers just fine. Brave does not.


#2

Hi @Brave_user,

Based on your screenshot, it seems it need a something like DRM plugin. I’m not sure where to enable it on Android, so let me cc @Serg and @LaurenWags for answer.


#3

You migth be right. However past versions of Brave played trailers without any problems. So either Amazon has changed something or there were some changes in Chromium/Brave.


#4

Hi @Brave_user

Does Chrome have the same issue?

Thanks,
Lauren


#5

No, it does not. I tested it.


#6

As of today Brave informs me with a pop-up that amazon.com needs to uniquely identify my device in order to play content (like a movie trailer). I can either allow or block this request. If I allow it movie trailers can be played.

So my best guess is that Amazon changed something about how they handle DRM content.

On my part the problem described in his thread has been solved (supposedly by Amazon). Thanks for all your input!


#7

Thanks for reporting back @Brave_user. Going to close this thread for now.

Best,
Lauren


#8