Brave does not allow sign-in on Pearson Education sites

bug
#1

Description of the issue:
Cannot log into https://www.pearsonmylabandmastering.com/northamerica/mymathlab/ or some other Pearson sites

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Browse to https://www.pearsonmylabandmastering.com/northamerica/mymathlab/
  2. Click "Sign-In"button
  3. Enter valid user name and password
  4. Click Sign In button

Actual Result (gifs and screenshots are welcome!):
Page reloads and clears login info without visible error.

Expected result:
Sign into website and access my account.

Reproduces how often:
Every time sign-in attempted.

Brave Version(See the About Brave page in the main menu):
Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional Information:
Works in Chrome Version 72.0.3626.121 (Official Build) (64-bit) without issue, as well as all other recent versions of Chrome for the past couple years. Works in Brave for Android (v. 1.0.88 in app store) as long as shields are down and pop ups allowed. Have replicated site settings from Chrome, and attempted log in with all shields disabled without success. Tried clearing cache and cookies in Brave. Using Win 10 64x

#2

@bwvanov Thanks for reporting. Can you try changing the shield settings to All cookies allowed and try again? Please revert back if it’s not working.

Thanks!

1 Like
#3

Hi, and thanks for the help!

That did not resolve the issue, however, I do have a development. I’m running Brave on a second computer at work, and visited the same site. Upon arriving at the site, I was warned that pop-ups weren’t enabled, so I enabled those, and disabled shields for the site. I attempted to log in following the steps above, and made it to a blank page at https://portal.mypearson.com/course-home#/tab/active, which is different from the starting domain. On this computer, I was not booted back to log-in, and so was able to disable shields on this new page and reload, and I’m in.

I don’t know what’s causing the difference in behavior between browsers. I’m using 64-bit Windows and the same Brave version on both machines (Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)

#4

@bwvanov Thanks for additional information. Do you see any error in the Developer Tool? If so can you paste the error here?

cc: @sriram

Thanks!

#5

Hey again,

Inspired by my success on the other computer I went nuclear, uninstalling Brave and deleting any lingering files I could find with Revo. Upon reinstallation, I was able to follow the same procedure I described above and get logged in. Not sure what was happening! I had tried in private mode (no extensions), clearing all browsing data, etc. But a thorough scrub and re-install has resolved. Thanks again for assisting!

#6

Could have been a cache issue. Clearing all data and restarting the browser and trying it should ideally fix the login issues. Going nuclear is the last resort. I wouldn’t recommend it unless its required. Clear data is the short version of going nuclear (for future references :slight_smile: )

#7

This was the first thing I tried. No joy.

closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.