Brave disabling Twitter push notifications

I am using Windows 11: build 10.0.22621.819, Brave version 1.45.133

While I am able to enable Twitter push notifications, Brave is disabling them after each session and I have to go in and manually enable them each time I launch Brave.

Any suggestions?

Thank you

Hello @chaserx, thank you for sharing your concern with us. Can you please verify the following setting under shields > advanced controls > set as allow all cookies

Additionally, please check if this option is enabled > brave://settings/socialBlocking > Allow Twitter embedded tweets and disabled brave://settings/cookies > Clear cookies and site data when you close all windows

Hope it helps. Regards


I didn’t notice you had replied. The settings are and have been set as you stated. regardless, Brave continues to disable my Twitter push notifications after I have enabled them. Repeatedly. Usually in 1-2 days.

Hello again @chaserx, I think you should enable Google services for push messaging in Settings. That way it’s should work.

That was done months ago. The problem still exists. 1-2 days after I enable push notifications for Twitter Brave disables them.

Hello @chaserx, thank you for reaching us out. By any chance do you have extensions installed? If so, try removing all of them or one by one to see which one might be causing the issue. Let us know if that makes any difference. Regards.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.