Brave (Desktop) Won't Launch: Javascript Error in main process (unable to find valid app)


#1

When I try to launch Brave browser (64 bit) on my Windows 7 desktop, an error window pops up with the following info (Brave doesn’t launch after):

[Main Instruction]
A JavaScript error occurred in the main process

[Content]
Uncaught Exception:
Error: Unable to find a valid app
at C:\Users<username>\AppData\Local\brave\app-0.18.31\resources\electron.asar\browser\init.js:125:9
at Object. (C:\Users<username>\AppData\Local\brave\app-0.18.31\resources\electron.asar\browser\init.js:172:2)
at Module._compile (module.js:571:32)
at Object.Module._extensions…js (module.js:580:10)
at Module.load (module.js:488:32)
at tryModuleLoad (module.js:447:12)
at Function.Module._load (module.js:439:3)
at Module.runMain (module.js:605:10)
at run (bootstrap_node.js:431:7)
at startup (bootstrap_node.js:155:9)

[OK]

I recall Brave working fine the last time I used it and I think it recently updated to the latest version.
I don’t recall seeing any other Javascript errors prior to this. I searched the forums here and github but didn’t see this issue addressed.

Any ideas or do I need to backup my profile/bookmarks and reinstall at this point?


#2

Exact Same error, Win 10 Home, latest updates. I can’t uninstall it either, get same error.

Besides Mickeysoft, last updates I remember are NCH Software, Winscp, Chrome. Sep 16.

Whats next step? Download new Brave and install over this corrupted one?
I will run whatever diagnostic you want. Installed the Git desktop and Atom a few weeks ago

Is this a reporting thing “C:\Users…” or is there no user associated with this?

Is this an electron thingie, whatcamacallit? Really, Equifax had a music major as their chief security person?


#3

@gmgj I was hoping to find the error’s source and how to resolve it but since no on answered, I just downloaded Brave again and installed it. I didn’t uninstall the previous version, I just ran the downloaded installer over it. That took care of the issue (note: I backed up my profile first, but when the reinstall was complete, my profile was still in tact).

I noticed that in the appdata/local/brave directory there were a few folders for different brave versions (running an exe for an old version launched that version fine). After the reinstall, those old version folders were gone. Maybe the new version conflicted with something in the old folders and the in-browser update didn’t clean up the conflict, while running the stand alone installer does.

Hope this helps you and anyone else with this problem.
Note: To back up your profile, go to: c:\Users\user_name\AppData\Roaming\brave and copy the brave folder. If your profile is lost in a reinstall you can then just copy that directory back over.


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.