Brave deletes the allowed cookies rules

Description of the issue:

Brave deletes the allowed cookies rules

How can this issue be reproduced?

  1. add a site to allow cookies
  2. close Brave
  3. open Brave
  4. rule is deleted

Expected result:

The rule is saved until I delete it.

Brave Version( check About Brave):

Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit) on Windows 10

1 Like

@TopMax,
Can you check and see if you have the Clear cookies and site data when you quit Brave option enabled:

It’s also possible that you may have cookie data selected to be cleared On exit in Settings --> History --> Clear browsing data --> On Exit:

@Mattches
I have Clear cookies and site data when you quit Brave enabled, but it worked with this option yesterday. Am I right that this option respects the allowed cookies? Because I added sites to the allowed cookie rule and the side stay there even when I close and reopen Brave.

The option to clean the cookies on exit is disabled, because this deleted all cookies yesterday.

Screenshot_40

@TopMax,
Thanks for reaching out.
So on my end, here’s what I found when testing to make sure the function worked properly:

With a fresh profile, I have the following cookie settings:


Then, I visited both wired and reddit, which left cookie data behind

Then, I quit the browser and relaunched, which left the following cookie data:

It does seem to function the way you described it – can you perform a similar test and share the exact results with me?

1 Like

@Mattches
I did it exactly like you and it first worked with a fresh profile.

But than this happens:

I created a fresh profile as second profile and my first profile keeps running in the background / other window.
I did the same things you did and it worked properly while my first profile keeps running in the background.
So I opened and closed the second Profile and all rules worked but after I closed both profiles so that Brave is completely closed (with this option enabled Continue running background apps when Brave is closed) and reopened my first profile and then the second fresh profile all rules and saved cookies in the second fresh profile were gone.

1 Like

@TopMax,
Hmmm – that’s very strange…I can’t seem to reproduce this on my end – on both Windows or macOS.

I get the same behavior as described before. Do you have any extensions installed at this time?

1 Like

@Mattches
So, I think I know were the problem might be. I deleted my complete user data and started Brave like new installed. I tried to produce the error but it all worked fine (the rules were persistent).
So I configured the setting like before without any extensions or other data like bookmarks, passwords, sync or history… and tried again.
The result: Every rules I define is removed every time I close and reopen Brave.

Her are the settings:






Notes:

  • Fonts and Search engine on default settings

  • Site Settings on default settings except Clear cookies and site data when you quit Brave enabled

  • Clear browsing data on default settings except On exit:

Screenshot_49
Screenshot_50

Can you reproduce this?

1 Like

@TopMax,
Thanks for all the info – I figured it out.

So try to reproduce with everything the same, EXCEPT – in the [On exit] window, make sure the Content settings option is not checked, as shown below:

Note that while the rest of my checkboxes are unselected, I don’ think this should have any affect on the test – just make sure both the Cookies and other site data and Content settings options are deselected (also make sure you hit Save as well after deselecting – I made this mistake a moment ago and ended up very confused).

Generate some cookies, add some rules, then close/relaunch the browser.
Success?

2 Likes

@Mattches
Success :white_check_mark:

It works now perfectly. Thanks a lot!

Note: Maybe add a explanation for this on https://support.brave.com/hc/en-us/articles/360017989132-How-do-I-change-my-Privacy-Settings-, because I think that other people have or had the same problem (I found similar topics with no solution)

2 Likes

@TopMax,
Glad that worked – and yes, I’ll edit that article tonight. The reason it’s not there is because – to be quite honest – I’m not sure anyone realized that was happening :stuck_out_tongue:

I appreciate your patience and willingness to help out and troubleshoot the problem.