Brave deleted all my settings and all bookmarks


#1

Brave auto-installed the latest version, and in doing so, reverted all my settings to default and my bookmarks were completely gone. This is not acceptable; why and how did this happen?


#2

Hi @Anonymous,

As one who has caught this bug, I know how much it sucks, and am sorry you experienced it.

Are you on Windows, or a Mac? Can you please copy your info from about:brave so we can confirm if this matches an existing issue, or is a new issue we need to investigate separately?

Again, sincere apologies for this. This has been a really difficult issue to reproduce consistently, but is a top priority that the team is currently investigating and testing fixes for (if it is the same issue that I suspect it is).


#3

Name Version
Brave 0.14.1
rev 3de60d5
Muon 2.57.8
libchromiumcontent 57.0.2987.133
V8 5.7.492.71
Node.js 7.4.0
Update Channel dev
os.platform win32
os.release 6.1.7601
os.arch x64


#4

Thanks @Anonymous,

Again, sincere apologies for this happening to you. Really appreciate you reporting this and sharing the info we requested.

I am going to add this to the GH issue that the team is working on, and will link to it here for tracking progress.


#5

@Anonymous

I have added a link to your contribution here to the GitHub issue that our team is using as they continue to investigate.

I am going to close the thread here, since this is in the github queue and being actively worked on.

GH url for tracking progress: https://github.com/brave/browser-laptop/issues/5512

Thanks again for reporting this.


#6