Brave default browser makes Steam video's give green screen


I love this browser but there is only 1 problem.
I set the browser as default and deactivated hardware acceleration but when i open steam on my pc the video’s give a green screen. When I put another browser as default the green screen is gone, after that when i go back to brave as default the green screen is still gone but only for a while, a couple of days later the video’s in steam are again giving me green screens.

Any solution to this problem?

Brave 1.34.81
Windows 11
CPU: AMD Ryzen 7 2700X
GPU: Asus ROG Strix RTX 2070 A8G Gaming
Motherboard: Gigabyte X470 Aorus Ultra Gaming
RAM: Corsair Vengeance LPX with 2 x 8GB 3200MHz

@Smekke Let me clarify one thing, are you watching videos from the web browser or from the Steam client?

The client, but I never had this issue before, on the web everything works fine, and with different browsers the steam client also works fine just not with brave as default browser.

@Smekke Yeah, it’s weird. It shouldn’t play a part of videos playing in Steam. I do know people have expressed issues with Steam in the past and there were various steps on resolving. Such as:

In fact, I just looked so long that I lost the links I MEANT to share here and I don’t feel like going through the MANY linked I read. Next time I need to keep them open darn it.

Overall they say things like this one quote which was still in my clipboard:

Aech Apr 29, 2021 @ 10:31am

the year, 2021. Steam still hasn’t fixed these issues, I acutally found a fix for it though that works for myself. I just turn hardware video encoding off, then restart steam, then back on and one more restart of steam and it works for a while.

I know some talked about changing settings of the graphics cards, others spoke of changing hardware acceleration within the Steam client, etc. You’d think there would just be one simple solution or something, but oh no…

Hopefully @Mattches or one of the other Brave staff can check in on you later to provide some insight, but it’s a bit challenging since it’s not occurring within Brave or anything.


Thanks the part that Aech wrote worked for me! It’s really weird tho that it didnt happen with other browsers, but it works thats all that matters! Thanks!

1 Like