Brave Crashing Upon Startup

My Brave will not open. No matter how many times I click on or reinstall it! Help please!

All it keeps doing is closing before it fully opens.

Please Help!

1 Like

Update: I fixed it. Apparently there’s a bug that occurs after Brave Updates. I think it needs looking into.

I tried to install Brave for the first time yesterday and I can not launch it long enough to move my bookmarks or follow the starter steps for using the Browser. I have been searching for ways to resolve the issue on the Brave community but it seems it may be an issue that cannot be solved currently by a user as I have read over other posts and other users have been commenting on a recent update, I am unsure as to whether that is still applying to today, I also have no idea what to do about my issue, except post on here and hope for a solution. I was hoping you have one since you said you have resolved it.

@Darkhai Welcome to the community (you too @Sharnao). :slightly_smiling_face:

Can you please provide details of what you did to fix the problem? It will help community members who are experiencing the same problem and looking for a solution. Also, if this is a bug, need the details to check if there is already an issue report, or to open a new one, at Brave GitHub. Thanks. :slightly_smiling_face:


How did you fix this? I am having a similar problem.

I had a friend help with that. All he and I did was rename the application from the Directory and the app itself.

This is Version 1.40.109. Before the next update, Could everyone at Brave make a patch for this kind of problem?

I hope there is a fix for it soon. I do not want to go back to Edge again like I did when I was having this problem. Because my friend and I renamed the application in both name and Directory, I can’t really set this as my default Browser. And I’ve never had this problem happen to me since I first heard about it in 2018. Or maybe 2019, I can’t remember but what I do remember is that I had this browser for years.

It’s hard to explain the problem because I’m not sure it happens to a lot of people.

Are there steps for completing the renaming of the application and within directory?

I am still unable to launch Brave just a few days post update.


Go to the task bar icon, right click it, click properties, click open in folder or whatever, and change the .exe’s name, then go back and change the name in the properties’ path.

It’s probably something to do with Windows Updates creating some kind of conflict.

This is in reference to the .exe within my Program Files? Or simply the shortcut?

Do I have to rename it to something other than “Brave”? I am so far unable to replicate this fix.

Additionally, we seem to be using a different Windows version as my steps do not align with what you have listed perfectly. What exactly are the two different names you are updating?

ie. Rename #1 is the .exe (shortcut, or program file .exe?), rename #2 is the ‘location’ path within properties?

Please elaborate if possible, I would very much appreciate it.

Thank you

Yet very few users are suggesting any issue. I actually haven’t had any problems after updating either. So there should be another underlying issue somewhere.

Which version of Windows are you using?

Also, if you “fixed it” enough to be able to access it, think you can check for crash logs?

If you can access it and it has logs, then it would be good to create a Support Ticket at and advise of the information. You could also post here and see if Mattches or one of the other people from Brave swings by, but Support Ticket would at least guarantee they will see it.

1 Like

I have not been able to fix the problem, I am still trying to find a way and I don’t know whether anyone knows how to fix it. I am a first time user of Brave as I have not downloaded it before until the day before yesterday. It will load but then immediately closes and I do not why this is occurring, except that I have been reading the forums and seems others have been having this problem after updates but I don’t know whether the version I have is the latest from the Brave website. I am using windows 10 the latest version.

@Sharnao Try this:

  1. Restart computer. Did a restart work? Go to next if no.
  2. Open any other browser (including other working versions of Brave) and reinstall Brave using installer from the official site Download Brave. You should not lose any data, but just in case, if you have data you want to save, then backup your Brave-Browser folder. The path below is to the User Data folder. Just go up one.
  3. Close any open browsers, then right click on the Brave Browser icon and select Troubleshoot compatibility from the menu. Did this solve problem? Go to next if no.
  4. Disable anti-virus software if you have any. Did this work?
  5. You could also install Brave Beta to see if it is working. That would help with troubleshooting your problem.

If none of the above worked, then you should follow the topic linked below. @jlondonr created the topic and a more technical savvy community member is helping there. Since you have a similar issue, you can track that topic.

Finally, you should create your own topic and provide the information requested in the template. Include information on what you have tried and provide your OS version too.

Hope this helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.