Brave crashing on MacOS Mojave

Description of the issue:
Brave immediately crashes wih a segmentation fault

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  • double click on the Brace icon
  • start from command line

Actual Result (gifs and screenshots are welcome!):
I tried starting it from the command line:

*******:~ ****$ “/Applications/Brave Browser.app/Contents/MacOS/Brave Browser”

[0409/051945.301208:WARNING:process_memory_mac.cc(93)] mach_vm_read(0x7ffee1d5d000, 0x2000): (os/kern) invalid address (1)

[0409/051945.439022:WARNING:system_snapshot_mac.cc(42)] sysctlbyname kern.nx: No such file or directory (2)

Segmentation fault: 11

******:~ ****$ “/Applications/Brave Browser.app/Contents/MacOS/Brave Browser” --version

Brave Browser 80.1.5.123

Expected result:
Browser window opens

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Mojave 10.14.6
Brave Browser 80.1.5.123

Additional Information:
I tried deleting
/Applications/Brave Browser.app/
and re-installing with no impact.

@darjboy, welcome to Community!
Can you try opening from terminal again but but disabling hardware acceleration:
open -a "Brave browser.app" --args --disable-gpu

Having same problem.

Tried:
open -a “Brave browser.app” --args --disable-gpu

Still crashes

@darjboy
@sheckyclyde

Can you both try clearing the cache
rm -r /Users/***YourUsername****/Library/Caches/BraveSoftware/Brave-Browser
and restarting your computers

still crashes. can send you crash report if that helps

What version of Brave are you running?
Would you happen to have sync enabled?

If sync is enabled, open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-brave-sync

still not working. cannot even get into preferences as it crashes. Ran script anyway but it still crashes

Sorry. version 80.1.5.123

This did it for me,

Deleted the Brave-Browser folder then rebooted.

Can you please tell me where to find this folder?

rm -r /Users/YourUsername*/Library/Caches/BraveSoftware/Brave-Browser

You need to restart your computer after deleting your cache.

rm -r /Users/***YourUsername****/Library/Caches/BraveSoftware/Brave-Browser

You need to restart your computer after this.

Well, turns out I have to do this every so often.
rm -r /Users/ YourUsername */Library/Caches/BraveSoftware/Brave-Browser
restart computer
Presumably something in the cache is causing Brave to crash. At any rate not a sustainable solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.