Brave crashes within 10 sec of opening, I can no longer use this browser

Description of the issue: Within 5-10s of opening the browser it closes. “Brave Browser” then appears in the task manager as “Suspended”. I must restart my computer to gain access to the browser, but usually it triggers again within a few minutes so it isn’t worthwhile to use this browser anymore. I’m on Windows 10…on mobile Brave works fine.

How can this issue be reproduced?

  1. Not sure what is causing this, all I do is open the browser and it closes within a few seconds. Used this browser for over a year and never had an issues like this.
  2. I’ve cleared my cache, I’ve tried a new profile, I’ve tried an anonymous window, I’ve disabled GPU acceleration, nothing is helping

Expected result: Brave should not close by itself

Brave Version( check About Brave): Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)

Additional Information: I just downloaded and installed the “nightly build” and it is not crashing…of course I had to create a new profile, import my bookmarks and reinstall my extensions. No idea if it will eventually crash or if there is something in the nightly build that fixed it.


OK, the nightly build is working BETTER, but still within about 30min of using it I had 2-3 crashes/closes all one after the other in the period of about a minute. The nightly build is fine again now, but not sure what is going on. I do know that my non-nightly (stable) build doesn’t ever “fix itself” like that.

There is an issue with Win10 on some computers.

Go in to Settings
then to Additional settings
then to System
then turn off “Use hardware acceleration when available”

This may help. This is one solution that worked for me.

I have the same issue but I have Linux.

Dang, I wish. I had already disabled GPU acceleration as I mentioned to no avail. Thanks for the advice though.


On some Win10 Pro there is a compatibility issue with Brave.
You have to run it Win8 compatibility mode, but you will get a error message on start up so if it is running it is not that,

there are some dash commands to add to the startup icon but sorry to say I do not know what they are. I have seen them on this community thing. Good luck finding it.

It could be your Linux type and/or version. I run Ubuntu 20.4 and it works fine

Hi @kevers05
Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) unknown (64-bit)
Operating System: Manjaro Linux
Kernel: Linux 5.4.44-1-MANJARO

Hmm this must be a different issue, as Win 8 compatibility mode does not fix it and I had been running Brave on Win 10 for at least a year with no problems. No bueno

Do you have Sync v1 enabled in the browser? If so, that may be causing the crashes.

If you’re using Nightly and it’s mostly working but you also imported your browsing data form the previous version you may have imported whatever “bad data” that was causing the crashes. Can you try clearing your cache/browsing data and see if the performance improves?

1 Like

I am seeing a similar problem on Mac OS X Catalina. I restarted Brave to install an update, and after the restart I couldn’t use the browser at all. It won’t crash, but it’ll freeze and be unusable.

I’m having the same problem. Ever since Windows 10 did a major update late last week, Brave no longer works. I just downloaded the latest version this morning and installed it, but it still crashes after a few seconds. Useless! Too bad, because it had become my favorite browser over the last year or so.

I already have it disabled, however, the issue described above persists.

The radical fix is to uninstall Brave, then go into your C drive and find all the places Brave has left some folders:

C:\Users[USER]\AppData (there were some in both Local and Roaming)
C:\ProgramFiles (x86)

Either delete or move those folders somewhere else.
Reboot, then reinstall Brave from scratch.
Voilà, it works fine now, but you don’t have any of your previous settings or browsing history.

I do not have any sync enabled in the browser and when I imported my bookmarks I only imported boomark data via html. Day 2 of using the nightly build and haven’t seen more crashes since the couple odd ones I had at the beginning. Maybe I will uninstall, remove extra data and reinstall like @Tafirkhoo says.

The issue still exists. even on the latest Brave build.

same problem, i’m already using Beta, no crashes but it doesn’t show adds

I haven’t seen any crashes in the past week from using the Nightly build exclusively. I’ve tried the regular browser randomly throughout the week and it had continually crashed within 5-10s of opening. But get this–I just tried it again today and now it isn’t crashing. No idea how it fixed itself because even after rebooting multiple times it would still have had the issue previously, then today it’s just working normally again. I just opened about 10 bookmarks and it’s sitting there all stable again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.