Brave crashes whenever a file dialog opens

Description of the issue:

The browser crashes whenever a file dialog opens. It might be trying to save a page or trying to upload a file.

I’ve recorded a short video demonstrating the issue. I could only attach this very file because the forum supports dragging and dropping the attachments. This is not always the case.

There seems to be a similar topic/issue here. The other issue is on windows and it got stale.

How can this issue be reproduced?

  1. Run browser (/usr/bin/brave-browser-stable)
  2. Open any file dialog (to save or upload)
  3. See it crash

Expected result:

Not crashing :slight_smile:

Brave Version( check About Brave):

Version 1.39.120

This is the most recent version I got by following the instruction on

Additional Information:

It might be unrelated, but this is the output I get when running the browser from the terminal:

mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[196666:196760:0610/] After loading Root Certs, loaded==false: NSS error code: -8018
[196666:196666:0610/] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[196666:196666:0610/] Failed to call method: org.gnome.ScreenSaver.GetActive: object_path= /: org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/”

There’s no extra output when brave crashes.

1 Like


A simple text file for you to download. The contents are one word: “test”

testFile.txt (4 Bytes)

Download works, or not?

Hi @289wk ,

Thanks for having a look into this.

Yes. It crashed with this text file too.

To be clear. Downloading works, but the browser crashes after that.

I’m able to download files but I can’t interact with the browser after the file dialog opens.
I can’t interact with the browser so I have to wait for the download to complete, kill the browser and open it again.


Are you able to switch from GNOME to KDE?

And I wonder about some influence by something you may have added from:

that might be messing with ‘normal operations’.


Might be related:

Are you able to switch from GNOME to KDE?

Not at the moment. But I’ll experiment with KDE as soon as I’m able to.

The browser is working OK in the VM, and whenever I reformat the PC, so I guess it’s going to work fine.

I just don’t want to reformat the computer because this is a lot of work considering I’ll have to reformat it whenever the problem reappears.

And I wonder about some influence by something you may have added from:

Yes. I was also wondering about it. The thing is freedesktop has so many projects and transitive dependencies. It’s hard to identify what’s causing it.

One thing I tested was whether other applications were crashing when I opened the file dialogs, but no, only Brave is crashing.

I also restarted the computer in safe mode but got the same results.

Might be related:

That looks similar. I found lots of posts that look similar but not quite the same. For instance, this post mentions there’s some kind of animation after the file dialog. All of the other issues I’ve seen also got stale without a solution. :cry:


Any progress?

I was talking about the usual loading animation that any other Android loading screen has. That one with a round orange bar which rotates constantly depicting that the application is doing “something” in the background.

Basically, the image upload window just sits there indefinitely without loading any images in my device

1 Like

So… I tried everything you’ve recommended:

  • Reinstalling brave: Reinstalling with the recommended installation method on the brave website doesn’t work. The snap package, the default on ubuntu, worked, but it has lots of problems that had made me move from it before.
  • Installing KDE: Both the native version and the snap version worked on KDE. I have no idea what is having this effect on gnome though. The freedesktop warnings are no longer there since I removed lots of extensions. I’m even considering moving to KDE at some point because of this, but I can’t do it right now.
  • Removing all gnome extensions: No effect.
  • Removing all brave extensions: No effect.

So the problem is limited to the native version in Gnome, but no idea how to fix that.

Oh… and a I also reinstalled gnome from scratch. No effect. :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.