Brave crashes when trying to move bookmarks

Hello! Thank you for responding. I do not have that setting enabled as it does clash with the privacy aspect of the browser.

There are several crash IDs:
d15c0800-2578-4408-0000-000000000000
d05c0800-2578-4408-0000-000000000000
cf5c0800-2578-4408-0000-000000000000
ce5c0800-2578-4408-0000-000000000000
cb5c0800-2578-4408-0000-000000000000
ca5c0800-2578-4408-0000-000000000000
c85c0800-2578-4408-0000-000000000000

There’s also Local Context, not sure about that but I assume only the IDs are needed in this case.

When I do the whole process, it’s within brave://bookmarks (simply by going to bookmarks in utility menu).

Anyone able to help? @Mattches @steeven

1 Like

Thank you for the crash reports. I do not get these results on my end when testing on my Android browser. I’ve forwarded these crash IDs to our devs for review and hope to have more information for you here soon.

Can you also tell me whether or not you are using Brave Sync on this device?

1 Like

Brave sync is used between the two devices that have this issue.

Thank you for confirming. I have a dev taking a look at the crash reports now.

Doesn’t appear to be a Sync issue and no specific Brave code is coming up in the crash reports which may point to this being a Chromium issue rather than a Brave one. Still digging, thank you for your patience.

1 Like

I’m also having this issue with the Brave browser. I have a Samsung S20 FE. The first time I try to edit and create a new folder, it will just close the folder window and go back to the original bookmark. The second time I try to edit the bookmark and create a new folder, the whole browser crashes/closes and tells me there was an error and to wait for it to be fixed. I have attached the file showing the error message. Hopefully this helps to get it fixed.

2 Likes

@eyesofneed1 Hi and welcome to the community. Thank-you for the additional information. :smiley: Usually, Brave support asks that users post their own support requests, because details of problems can vary so widely. I think in this scenario, posting here to consolidate information is probably best. I’m sure we will be informed if it isn’t. lol

Can you please provide the below information to help troubleshoot.

  1. Do you have this setting enabled at brave://settings/privacy?
    image

  2. Would you please go to brave://crashes and see if you have any crash ids and post the ids if there are any displayed? If you have the above setting enabled, there may not be any listed.

  3. Do you have a lot of bookmarks too?

  4. What is your Brave version?

Thank you for the quick response.
I’ve checked and I did not have the “automatically send diagnostic reports” setting turned on. I have now turned it on.
Here is the screenshot from my crashes page.


Yes, I do have a lot of bookmarks. Is there a limit on how many bookmarks are supported?
I have Brave version 1.39.115.

Can you please tap the Send now buttons on that page and copy/paste/reply with the IDs that are generated once the reports are sent?

Thank you

I’ve done that. I just checked my bookmarks. I thought I had a lot, but I have less than 60 bookmarks. That’s a lot less than I had when using Google Chrome.

@eyesofneed1,
Thank you for the information. I’m actually curious if you have Chrome installed and/or if you try to do the same thing in Chrome whether or not you get the same results?

@Mattches,
I decided to try Chrome, newest version of Chrome: 102.0.5005.78 on tablet and the issue occurs there as well and it is exactly the same process.

1 Like

Yes, it happens with Chrome also. However, with Chrome, it just says that Chrome isn’t working and asks if you want to close the app. I’ve tried to find where to fix it for both apps, but am not having any luck.

Also, for comparisons, I have a total of 246 bookmarks in Chrome. I can add bookmarks to each browser, but cannot change the parent folder when adding a new folder.

Any help or advice is greatly appreciated.

2 Likes

@Mattches,
I just sideloaded the pre-release stable version v1.39.123 (Chromium 102.0.5005.125) and there’s no difference.

I want to add that I have tried both Vivaldi, latest version (Chromium 102.0.5005.125) and Bromite, latest version 102.0.5005.96.

Vivaldi worked as it should and as for Bromite, the issue occurs in the same way as in both Chrome and Brave.

Is there a way for us users to be able to determine what might be causing this issue? Anything would be greatly appreciated by both @eyesofneed1 and I.

Yeah so this is an upstream Chromium issue that needs to be resolved. When this happens it’s typically just a waiting game for the chromium team to address/fix the issue.

Is there an issue in the tracker? I didn’t find one in the chromium source.

I went to GitHub and saw that there was a new pre-release stable version: 1.40.101 (103.0.5060.42) and I tried it out on the phone and the issue does not occur and I’m going to try on the tablet and see if it’s working on it as well.

EDIT: It works on the tablet as well. Now, I hope this works for others as well with the same issue.

4 Likes

Are you meaning a new version of the Brave browser?

Yes but it’s pre-release so to get that you’ll need to sideload the current version and I have only sideloaded to see if the issues would disappear and it did.

Chromium team must’ve fixed it with Chromium 103 but I don’t know when it’ll be available as a stable version on Google Play Store.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.