Brave crashes when opening a particular site


#1

Steps to Reproduce

  1. Start Brave
  2. Enter http://nyheter.se in the URL field

Actual Result: Brave crashes and disappears from the task list.

Expected result: Should display the site even though it does not have a HTTPS version.

Reproduces how often: Every time.

Brave Version(about:brave):

Brave 0.23.73
V8 6.8.275.24
rev 50bdb6d
Muon 8.0.3
OS Release 6.1.7601
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows 7 Professional SP1
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 68.0.3440.75

Reproducible on current live release (yes/no): Yes

Additional Information:
Contents of debug.log below:

[0801/165310.977:ERROR:http_transport_win.cc(273)] WinHttpSendRequest: A security error occurred (0x2f8f)
[0801/165745.955:ERROR:http_transport_win.cc(273)] WinHttpSendRequest: A security error occurred (0x2f8f)


#2

Hi @jek6094

I’m unable to reproduce the crash, could you please navigate to chrome://crashes and post the Uploaded Crash Report IDs from when you tried to visit the site and got a crash?

Thanks,
Lauren


#3

Sure, here they are:

Local Crash ID c7f4a53c-23c0-44aa-ac55-5dce4ef5925c
Crash report captured on Wednesday, August 1, 2018 at 5:12:48 PM (upload requested by user, not yet uploaded)

Local Crash ID a1c5481f-ddb6-4f4b-ad27-3d2ca6d4db2a
Crash report captured on Wednesday, August 1, 2018 at 4:57:45 PM (upload requested by user, not yet uploaded)

Local Crash ID 4bb6e10a-808f-4b59-adc1-2131c4cd8232
Crash report captured on Wednesday, August 1, 2018 at 4:53:10 PM (upload requested by user, not yet uploaded)


#4

@LaurenWags I just tried and can confirm the crash. Just uploaded, Lokale Absturz-ID: a26ad1e4-46ca-428a-80ef-75d547184eb0

Brave: 0.23.73
V8: 6.8.275.24
rev: 50bdb6df42550dd14f5636770ec8585aa26e361b
Muon: 8.0.3
OS Release: 6.1.7601
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.75

On Windows 7, too. Hope this helps :slight_smile:

Edit: What does “Absturzbericht erfasst: Mittwoch, 1. August 2018 um 21:05:36 (Upload wurde vom Nutzer angefordert, aber noch nicht abgeschlossen)” mean, do I need to do something specific? I’m still in the office (having a bit of fun after work) but I wanted to go home soon…


#5

Thanks @jek6094 - once these crash reports are uploaded, can you post the Uploaded Crash Report Ids? (this value will display on the same line as the Local Crash ID)

Thanks!
Lauren


#6

@tlaloc77

There’s probably a link to that says something like ‘manually upload’ or ‘request upload’. Could you do this for these reports and then send the Uploaded Crash Report ID once the reports have been uploaded?

Thanks,
Lauren


#7

@LaurenWags What do I need to do to upload them (in case you are interested in mine, too)? It looks like clicking on “Jetzt senden” (upload now?) doesn’t do anything useful.


#8

Yep, Upload now should do it. You probably have to close the page and come back to see if that link is gone. It might change to “(upload requested by user, not yet uploaded)” once you leave the page and come back.


#9

Thank you - I see the German version of “(upload requested by user, not yet uploaded)”. Is that all? I’m asking because it’s the 3rd time I clicked on “upload now” (in German) and I still don’t see that a report got uploaded.

Edit: How big is the uploaded crash report??! I hope it doesn’t try to upload my whole memory content, that would be 8GB.


#10

Hi @tlaloc77

As far as I know, that’s all that needs to be done at the moment. Whenever you come back to the machine (tomorrow if it’s end of the day for you is fine!) just check and see if they were uploaded and post the Uploaded Crash Report ID :slight_smile:

Best,
Lauren


#11

Thank you once again. So, 'till tomorrow then, I’m off now.

Edit: I just re-loaded chrome://crashes and the topmost item looks like this now:

Lokale Absturz-ID: a26ad1e4-46ca-428a-80ef-75d547184eb0
Absturzbericht erfasst am Mittwoch, 1. August 2018 um 21:05:36, wurde nicht hochgeladen

“wurde nicht hochgeladen” = did not get uploaded. I’m kinda weirded out now :cold_sweat:
Anyway, I quit for today.


#12

My browser is also crashing. It happens a lot. 5 in the last 10 minutes:

Uploaded Crash Report ID 82b9c671d02748ed (Local Crash ID: 1234ba34-6d22-4740-aed6-52483f44b53a)
Crash report captured on Wednesday, August 1, 2018 at 4:40:00 PM, uploaded on Wednesday, August 1, 2018 at 4:40:01 PM

Provide additional details

Uploaded Crash Report ID e434c2784afc0fcf (Local Crash ID: dff06b9e-9cdb-4b81-b523-ad5b68fec86f)
Crash report captured on Wednesday, August 1, 2018 at 4:37:12 PM, uploaded on Wednesday, August 1, 2018 at 4:37:13 PM

Provide additional details

Uploaded Crash Report ID c597feef969f831a (Local Crash ID: 30940bd8-1a06-4c27-af36-2675402d9fa5)
Crash report captured on Wednesday, August 1, 2018 at 4:33:08 PM, uploaded on Wednesday, August 1, 2018 at 4:33:09 PM

Provide additional details

Local Crash ID eef9c8c8-529c-45d2-8529-a8950fa31b56
Crash report captured on Wednesday, August 1, 2018 at 4:28:59 PM was not uploaded

Send now

Uploaded Crash Report ID e81b124f5efcf6dd (Local Crash ID: f3dac1e6-1760-4e4e-8481-4e7541d76d56)
Crash report captured on Wednesday, August 1, 2018 at 4:28:23 PM, uploaded on Wednesday, August 1, 2018 at 4:28:24 PM

Provide additional details


#13

Thanks @tlaloc77 - tomorrow is another day. We can give it a try then.

@cryptojewsusman - do specific URL(s) seem to trigger it? Those would also be helpful.


#14

In my case, it is only the URL in the post that crashes the browser. Everything else so far works fine.
It seems the crash reports have changed status to “was not uploaded”. I just clicked “Send now” again. Is there something more I need to do, or should the upload happen by itself?


#15

The upload just won’t happen it seems. As soon as I quit and restart Brave, they go back to “was not sent” status. I did however locate the crash dump files on my hard drive and got them zipped and uploaded to my web space. If it is in any way useful to you, they are located here for the time being: http://racehub.se/brave/brave-crashreports-jek6094-20180801.zip


#16

The Chromium help pages (https://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug) mentions one crash report configuration setting. Brave has that setting split in two though. Does both of them have to be enabled for automatic uploads to work properly?


#17

Same here. I tried 4 or 5 times. I don’t have a web space, could I send them per email (in case they are still useful/needed)?
@jek6094 Can you give me a hint where I find them? I searched for files with “crash” in the name or in the content and found only ones that are clearly unrelated to brave.


#18

Sure! On my Win7 system they are located under C:/Users/…/AppData/Roaming/brave/CrashPad/reports.

Side note - The upload status actually went to “Was not sent” even when not restarting Brave. It took a little while for that to happen though. I wonder to what location/URL they are uploaded. Maybe it’s an access issue of some sorts?


#19

Could you both try enabling the crash reports in Preferences > Advanced to see if that helps?


#20

Mine was enabled by default, and I haven’t touched it since the installation. The other setting (“Automatically send usage statistics to Brave”) is off though. I did try a crash report upload with it enabled, but the upload still didn’t work.

EDIT: Fwiw, I see two javascript console errors on the chrome://crashes page:

chrome.guestViewInternal is not available: 'guestViewInternal' is not allowed on chrome://crashes/.
chrome.tabViewInternal is not available: 'tabViewInternal' is not allowed on chrome://crashes/.

Probably not relevant at all, but anyway.