Brave crashes/quits/closes when I try to submit forms

bug

#1

Brave instantly crashes/quits/closes when I try to submit forms on websites such as timeout.com and networkrmit.com

Does not happen in the Opera browser.

If there is known Brave Shield settings that will prevent this behaviour from occuring, please advice which ones.

Love the browser!

Many thanks,
Ole


#2

I experience the same problem. This is very annoying and is happending after the last update of Brave, which was on april26th if I recall correctly. Everytime I have to submit a form, I now have to use FireFox, as Brave crashes and all entered data is gone. Running Brave on Windows 7 64bit.


#3

I am having the same problem on my windows 10 desktop. As soon as a form is submitted brave will crash. It started after the update I performed on 4/26/18.


#4

Same problem here - I also started encountering it yesterday after the update.
Please don’t make me switch to Chrome to fill in forms please! :wink:


#5

Same here. Since last update, every time i try to submit a form it crashes.


#6

Same. This is stupid. Clearly the last update caused this.


#7

Ditto. Trying to update settings, submit forms, and generally be productive. Have to use chrome until fixed.


#8

Hi @olecalfheim @Wesz @farfo @ironanne @to.andrade @beefstew @WellspringCBD.com,

It’s a known issue with this release version. See V0.22.667 for laptop has been released!.
The fix will be available soon.

Best,
:slight_smile:


#9

Same issue here. Running the following versions listed below. I wanted to sound off as I don’t see any users listing macOS as their OS in this thread specifically. This happens when submitting just about any input on my end (including a Tweet, occasionally on trying to log into a website, and on traditional form fills).

Additionally, Brave Helper has been duplicating itself in Activity Monitor on macOS, running as high as 30% of my CPU usage at times, and running my Macbook’s fans continually. Glad to see an update coming for form fills, and hoping it solves the issue for all platforms, but this version of Brave seems to be creeping up on usage issues similarly to Chrome.

Machine:

Macbook Pro (15-inch, 2016)
macOS High Sierra 10.13.4
2.9 GHz Intel Core i7
16 GB 2133 MHz LPDDR3

Brave Version:

Brave - 0.22.667
V8 - 6.6.346.24
Rev - 0433b26
Muon - 5.2.6
OS Release - 17.5.0
Update Channel - Release
OS Architecture - x64
OS Platform - macOS
Node.js - 7.9.0
Brave Sync - v.1.4.2
libchromiumcontent - 66.0.3359.117


#10

We just released 0.22.669 [1] which fixes the issue. Again, apologies to everyone that was affected.


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.