Brave crashes (or quits) after Enter/Return key (RESOLVED)

The DuckDuckGo extension was causing the issue.
I was using it to see website ratings more than the actual blocker. I disabled it.

Brave seems to quit or crash after I hit the return or enter key. It doesn’t matter if I type in a text box, search in the URL, anything. It will randomly close out every window I have open and not just the working window.

I have:
restarted my computer
cleared cache/memory because why not
tried brave using a different keyboard
uninstalled and reinstalled the browser

This only started since the last update, a few days ago.

Description of the issue:
How can this issue be reproduced?

  1. Type something, anything, anywhere
  2. Hit Enter or Return key

Expected result:
4/5 times Brave crashes and closes out all tabs and windows. Open brave and it asks to restore tabs 1/3 times

Brave Version (check About Brave):
Version 1.15.75 Chromium: 86.0.4240.99 (Official Build) (64-bit)

Additional Information:
It is not a memory or cpu issue as it happens even when it is the only application running.

Extensions: Keeper, LanguageTool, Decentraleyes, HTTPS Everywhere, Privacy Badger, uBlock Origin, Workona.

As of right now, I know it is definitely not HTTPS Everywhere, or Keeper

VPN: Express

could you disable all extension

For now, that appears to have worked! However, this was never a problem until the Brave update. I see how it might be compatibiltiy issue but I’ve been using Brave for about a year now and this is the first time this has happened.

Any suggestions? Less some of the blockers, I actually rely heavily on LanguageTool, Workona, and Keeper.

now try to enable them one by one till you get the one that cause the issue

Is it when you use the Tor option or the regular Brave?

Also. Try this for me.

  • Type an easy to enter URL somewhere other than the URL bar (for example, open notepad and type www.reddit.com )
  • Cut the URL you typed, right click the URL bar in Brave, select “paste and go”
    Does the browser still close?

Thanks!

Hello @MrHarleyQuinn

it work fine i copied it to texteditor on linux then cut then right click then paste and go

could you try to create new profile just for testing to see it still there or not close all other window after create the new profile

and you welcome

Are you on windows 7?

nope linux centos :slight_smile:

@MrHarleyQuinn Regular private mode, windows 10
@justsomeone1 I’ll try that!