Brave crashes instantly on my Mac


#1

Yesterday I downloaded the most recent version of Brave for Mac OS X.

However, as soon as I open it, it crashes. Every time.

The exact same thing happened to me once before when trying out another browser (Opera), although I checked yesterday and Opera now (2 or more years later) seems to work fine.

It looks to me like Apple have set Macs up so as to make it hard for users to choose a different browser to Safari.

Is this a possibility? If so, how can I fix it?


#2

We have an issue logged for this: https://github.com/brave/browser-laptop/issues/12744

Thanks,
Lauren


#3

Hi @JamesP

Cross-posting:


#4

Thanks, Lauren. Will try it.


#5

Hi Lauren,

No joy - just keeps crashing.

Could Apple have installed some kind of malicious script on my computer that prevents it from opening?


#6

Thanks for trying @JamesP

I don’t think that’s the case. Brave 0.19.139 and above uses Chromium 64, whereas Brave 0.19.134 uses Chromium 63. I’m wondering if the change in Chromium versions caused this issue. Either way, I’ll share your findings with the team. Thank you!

Lauren


#7

Same for me, Lauren. Still won’t open with the new version.


#8

By way of background, this happened to the same version of Brave that had been running successully for me for several months. It just started crashing like this about 5 or so days ago.

It is exactly the same experience I had with Opera about two years ago. It ran well for a few months, then suddenly crashed on start up and, once again downloading newer versions made no difference. The similarities between the two experiences make me very suspicious about Apple. They do seem to try to coerce you into sticking with Safari.


#9

There’s nothing in macOS that interferes with the ability to switch browsers—I have 12 browsers installed that aren’t Safari:

54%20AM


#10

And they all work fine?


#11

Of course. I’m a web developer; I have to be able to use and test in all browsers.

Whatever you’re experiencing, it’s not because Apple is somehow sabotaging other browsers—most devs I know use Chrome as their default browser.

I’m successfully using Brave everyday…


#12

Have you tried using OS X 10.9.5? That seems to be the problem.


#13

Short answer: no. I’m on a 2009 iMac that shipped with OS X 10.6 back in the day; it’s now running macOS 10.13 High Sierra.

OS X 10.9 Mavericks hasn’t been supported or updated by Apple for some time—10.9.5 was released September 2014. I guess we’ll have to wait and see if the Brave team can continue to remain compatible 10.9.5.


#14

I got mine working by downgrading to 0.19.131

https://github.com/brave/browser-laptop/releases/download/v0.19.131dev/Brave-0.19.131.dmg


#15

Thanks, will try doing that today!


#16

OK, worked ONE TIME only, then started crashing on start up again.

I’m convinced a bug of some kind is being installed covertly on my computer that is causing this to happen.

Also, it will not allow me to copy and paste the error log.


#17

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.