Brave crashes immediately upon launching on PC, Win 10

Tried to uninstall and reinstall, as well as reboot PC

I have the latest update as of May 31st.

Nothing changes…

please advise

Hi @Neo1, Welcome to Community!
Can you try opening command prompt and enter this command:
"C:\Program Files BraveSoftware\Brave-Browser\Application\brave.exe" --disable-gpu
or
brave.exe --disable-gpu