Brave crashes as soon as I start it up, worked fine for months


#1

Hello,

I’m having an issue with the browser (even had to use another browser to report it :stuck_out_tongue: )
The moment I try to open the browser it freeses, it doesn show the first page, but it freezes instantly after. Whenever I click anywhere I get the ‘not responding’ pop up.

I’m using windows 10, but I’m not sure what my Brave version is. Can’t really check since I’m not getting past the homescreen. When I click properties in the taskbar it says app-0.22.810 somewhere. Is that the version?

I already restarted my computer, not sure what else I can do


BUG: doesn't work after update
#2

I have the exact same issues here. I’m using Windows 10 version 1803 and I’m pretty sure Brave’s fully up-to-date. I can run Doom 4 at 1080p at 60FPS on high settings, so it couldn’t be my computer just not being able to process it. I have five home page tabs, but they’re all low-intensity sites like my email, a forum, and an altchan site.

This issue has rendered me unable to import and export my bookmarks, change my hompages, or run diagnostics of any other kind. Whatever’s happening, it wasn’t this bad twelve hours ago when I was using my browser to read Berserk!


#3

I’m using my laptop for 3d modeling, so it should run anything just fine :stuck_out_tongue:
When I start Brave he makes a lot of noice though (from the fans)


#4

Anyone here have similar issues? If we raise enough of a stink we’ll get a faster response, people.


#5

I don’t know what happened actually. After a full day it still doesn’t load.
Is it possible it’s because of an update? Maybe I should downgrade


#6

Same here, minus the months and a reasonably old laptop instead of high end machines. Just installed Brave recently, it was working perectly fine when, around date change from 20th to 21st, it froze and after I task manager killed it, it now insta-freeze as soon as it is started. My suspicion is that something with the distribution of the free BAT is causing it to bug out (because of the timing).


#7

Same here on macbook pro with osx 10.13.4… can’t use brave anymore since today…


#8

Yeah same here. I’m running Linux Mint and was on 4 chan when mine crashed. Ever since it will just load the first page then freeze! I ran a upgrade on my OS, thx brave support ;), like was suggested and now cinnamon is crashing altogether. And Brave still doesn’t work! lol


#9

apparently the issue is resolved in the next update


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.