Brave crash upon opening

well I opened Brave and it automatically downloaded and opened the last update, so I closed Brave and then updated… But now every time I open Brave after updating, it just freezes and crashes, and I get this Apple Report about the crash:
I’m going to try install it again or redownloading…

I am also experiencing the same problem since 2 days ago.

I have narrowed the problem down to “Brave Ad Block”. Some filters, or selecting all of them at once, cause this behavior.

The only solution I found for this, is to manually change the state of the selected filters in the settings file “Local State”.
To do this navigate to: C:\Users<USERNAME>\AppData\Local\BraveSoftware\Brave-Browser\User Data and locate the file “Local State”. Open the file with notepad and at about the beginning you will find:
a little further down you will find:
followed by the ID of each filter and it’s state (true or false). What I did is used the replace function in notepad and changed the state of each filter to false. Just be mindful to not overdo it and start changing settings with the replace function. For me the Adlists go up to the point where it states the darkmode status.

To whoever mod it may concern: This was not triggered by a settings change. It was probably triggered by an auto-update in the weekend and I can still reproduce it up to this time by enabling all adlists.

I hope this helped,
Thank you


that would be helpful, if I was having that issue on Windows that is…
I forgot to specify the OS but I did say “I get this Apple Report”… so an Apple Report for a crashing app would only be on a Mac, not Windows…
Anyways thanks, my solution was to change to Brave Nightly, it works fine, but I don’t have any of my previous bookmarks, history, passwords, etc…

I don’t know about MAC but in windows the normal, beta and nightly versions are entirely different programs so they don’t use each others data. If I where you, I would search where Brave saves it’s data on MAC and try the same method I described.

If you didn’t delete them yourself, I think all your data’s still in there.

Check below:

didn’t work either:


Suggestions . . .

Open 2 windows.

In Terminal window 1, enter:

top -o +command -O +pid -stats command,cpu,state,rsize,pid

In Terminal window 2, enter:

open -a “Brave” -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

That command will start Brave Browser with Hardware Aceleration DISABLED, and using a New Private Window.

If Brave Browser runs long enough, so that you can look at its appearance in Terminal window 1, that may interest.

If / when Brave Browser crashes, Terminal window 1 may interest - again, maybe.

All your Apple Mac OS Crash Reports point to

Identifier: com.brave.Browse [the Brave Browser]
Crashed Thread: ThreadPoolForegroundWorker


[Apple - Developer:] Understanding the Exception Types in a Crash Report:

A portion of that, in detail [I dis-assembled Apple’s paragraphs, so I could read it more easily]:


The breakpoint exception type indicates a trace trap interrupted the process. A trace trap gives an attached debugger the chance to interrupt the process at a specific point in its execution.

On ARM processors, this appears as ‘EXC_BREAKPOINT (SIGTRAP).’ On ‘x86_64’ processors, this appears as ‘EXC_BAD_INSTRUCTION (SIGILL)’.

The Swift runtime uses trace traps for specific types of unrecoverable errors — see

[Addressing Crashes from Swift Runtime Errors]

for information on those errors.

Some lower-level libraries, such as


trap the process with this exception upon encountering an unrecoverable error, and log additional information about the error in the ‘Additional Diagnostic Information’ section of the crash report.


[Diagnostic Messages]

for information about those messages.

still crashed:
Here’s the last screenshot i took while it froze:

I’m going to use Brave Nightly for now… seems to be working fine…

I’m on Fedora 31 (KDE Plasma) and this fixed the issue, so it’s not just a windows work around. The official fix didn’t fix it.

1 Like

The official response didn’t fix it, manually editing local state as said above fixed it after only a few of them where disabled, thank you so much, now I don’t have to spend any more hours manually filtering through a mildly corrupt port of my history in gugl chrome!


I tried to find that same file on Mac, found it, but didn’t find that “regional_filters”, here’s a screenshot:


I found that file, too; and similar to yours, the “Local State” file also does not show anything like, what “nivakis” reported above - re the ID of each [regional] filter and its state.

It has to do with how/where Brave is programmed to store it’s settings on Mac. If you don’t mind reconfiguring your Brave, all you have to do is delete this file, at least on Windows.

If you DO mind reconfiguring, at least try to move this file somewhere else (or renaming it) so you can confirm that this is causing the problem and then restore it to it’s original name/place.

I would also search for the “Local State” file in other directories, or I would check every other file in that directory to see if the adblock settings are in another of these files.


Maybe take a look at Spotlight - under System Preferences on your Mac.

You might want to add - under the Privacy tab - the Brave Browser app that is within /Applications

/Applications/Brave Browser

And, add at least 2 Caches folders, plus the following BraveSoftware folder:

/Users/your_user_shortname/Library/Application Support/BraveSoftware

If you have been watching your Activity, you might see a process named “hiutil” — using a lot of CPU, either after a Brave Browser update, or after you make a change, anywhere within

/Users/your_user_shortname/Library/Application Support/BraveSoftware


EDIT - added Aug. 11, 2021:

After Quitting Brave Browser and running a cache cleaner, I borrowed this idea:

and I deleted everything (including the “LICENSE” document(s)) within:

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/CertificateRevocation

and again deleted what was previously recommended by Brave Support (the “cffkpbalmllkdoenhmdmpbkajipdjfam” folder):

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/cffkpbalmllkdoenhmdmpbkajipdjfam

I did not edit the “Local State” file. It has not changed - in the area of interest:

Screen Shot 2021-08-11 at 6.55.05 AM

Upon startup of Brave Browser, here are the results (today, Aug. 11, 2021) - a new folder within “CertificateRevocation” and a new “cffkpbalmllkdoenhmdmpbkajipdjfam” folder:

Screen Shot 2021-08-11 at 6.53.19 AM

After the startup of Brave Browser, there was the lone folder “1.0.1028” within the new “cffkpbalmllkdoenhmdmpbkajipdjfam” folder . . . but a little while later, a folder “1.0.1027” for yesterday, also showed up:

Screen Shot 2021-08-11 at 7.08.32 AM

Other than opening 2 New Private Windows in Brave Browser, and editing / updating this reply 14, I have not otherwise used Brave Browser since the last startup . . . and Activity Monitor shows for memory:

Screen Shot 2021-08-11 at 7.18.02 AM

and for CPU:

Screen Shot 2021-08-11 at 7.20.13 AM

I cannot account for why the CPU Time column indicates, what seems to be accumulated time (from before this morning’s testing-and-editing work) for Brave Browser and one of the Brave Browser Helper (Renderer)'s.

I Quit Brave Browser; and started up again; and both of those processes have been adding CPU time in heaps — esp. the Brave Browser Helper (Renderer).

This topic was automatically closed after 30 days. New replies are no longer allowed.