"Brave could not access your operating system's safe storage" but I have added it to keychain access

Description of the issue:
I recently had to reset my default keychains because of an issue with another app. As a result a few things have been reset and stopped working.

Brave now says that it does not have access to my OS’s safe storage and as a result can’t sync. I have followed the guide in the link in the settings shown when this happens.

As you can see, everything is enabled correctly and yet I still get the error.

I have also reset all settings, removed the app, reinstalled the app, to no effect.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Reset default keychains on macOS

Reproduces how often:
Can’t correct to attempt to reproduce

Brave Version(See the About Brave page in the main menu):
Version 1.45.113 Chromium: 107.0.5304.62 (Official Build) (arm64)

Type of devices currently running on the Sync chain in question:
iPhone 14, Macbook Pro M1 14"

Additional Information:

Ok, I have removed the /Application Support/BraveSoftware folder and started fresh which seems to have fixed the issue.

1 Like

Glad to hear you resolved the issue, strange that that was the particular solution but glad it worked nonetheless.