Brave components update error

Description of the issue:

I tried to update the components that are version 0.0.0.0 as guided so that my brave shield would work, and also tried connecting to a mobile hotspot, but it just won’t update and says update error every time. I’ve tried 4 different networks, and I’m pretty sure it’s not a network problem. I’ve tried with VPN on and off, both not working.

**Steps to Reproduce (add as many as necessary): 1. Fix the error of update error or tell me another way to let my brave shield work. **

Actual Result (gifs and screenshots are welcome!):

Tried lots of different networks as well as mobile hotspot, VPN on and off, in every way, the components update will show update error.

Expected result:

Updated successfully and brave shield working.

Reproduces how often:

Always.

Operating System and Brave Version(See the About Brave page in the main menu):

MacOS Monterey 12.1 Brave version: 1.38.109

Additional Information:
No.

Guys, I solved the problem by using Express VPN. Long live Express!