Brave.com download page on Windows 10 using Vivaldi displays two buttons with the exact same text, not indicating which is which version


#1

Description of the issue
When navigating to brave.com to download the browser on Windows in a Vivaldi browser you are greeted with a page showing two large buttons that both say “Download Brave for Windows”. It at first blush appears to be a major graphical glitch but it turns out that one is for 64-bit and one is for 32-bit and the current only way to find out is to click both and download them or to hover over them and check the link.

(sorry if this is the wrong place for this but it seemed like the best fit given the options I was presented with)

Exact URL of the website in question

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)
n/a

Does the site function as expected when Shields are turned off? (yes/no)
n/a

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)
n/a

Does the site function as expected when using Chrome? (yes/no)
The website functions as expected in Brave but I do not have Chrome installed to test with that.

What Brave version/Build are you using when you encounter the issue?(About Brave info)
Brave version it worked in: Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)
Vivaldi version it did not work in: 1.15.1147.47


#2

@bozarjp, good lookin’ out!
Sent to our web devs to fix - should be resolved shortly!
Really appreciate you pointing this out.


Why there are 2 download links on Brave Beta and Brave Dev page?
#3

+1 from @nellaiseemai via Why there are 2 download links on Brave Beta and Brave Dev page?


#4

@bozarjp @nellaiseemai,
Apologies for the late reply. Can either of you confirm whether or not this still displays two links?
If so, would you mind providing your User-Agent strings? We’re unable to reproduce this on our end (only one link displays on macOS, Windows and Linux when visiting DL page for any Brave Build). We can use this information to derive why you may be seeing more than one link.
To find your UA-String:

  1. In Brave, open the main menu, navigate down to More Tools --> Developer Tools
  2. The developer tools console should appear. If Dev tools opens up to something other than Console, simply click on the Console tab to switch views:
  3. Once in the console, enter the command navigator.UserAgent
  4. Your user agent string will be displayed below. Copy this information and paste it in a reply here.

From there, I can forward this information to the web dev team so they can see what may be causing this. Appreciate both of you bringing this to our attention!


#5

Hello,

It is still showing 2 links for me and when I checked that variable it is undefined. Here is the rest of the navigator object, though.

Navigator {
    appCodeName:"Mozilla"
    appName:"Netscape"
    appVersion:"5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.183 Safari/537.36 Vivaldi/1.96.1147.47"
    budget:BudgetService {}
    connection:NetworkInformation {downlink: 10, effectiveType: "4g", onchange: null, rtt: 50, saveData: false}
    cookieEnabled:true
    credentials:CredentialsContainer {}
    deviceMemory:8
    doNotTrack:null
    geolocation:Geolocation {}
    hardwareConcurrency:2
    language:"en-US"
    languages:(2) ["en-US", "en"]
    maxTouchPoints:0
    mediaDevices:MediaDevices
    ondevicechange:null
    onLine:true
    permissions:Permissions {}
    platform:"Win32"
    plugins:PluginArray {0: Plugin, 1: Plugin, 2: Plugin, Chromium PDF Plugin: Plugin, Chromium PDF Viewer: Plugin, Widevine Content Decryption Module: Plugin, length: 3}
    presentation:Presentation {defaultRequest: null, receiver: null}
    product:"Gecko"
    productSub:"20030107"
    serviceWorker:ServiceWorkerContainer {controller: null, ready: Promise, oncontrollerchange: null, onmessage: null}
    storage:StorageManager {}
    usb:USB {onconnect: null, ondisconnect: null}
    userAgent:"Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.183 Safari/537.36 Vivaldi/1.96.1147.47"
    vendor:"Google Inc."
    vendorSub:""
}

#6

@bozarjp,
That’s my bad! Can you perform the same command with the ‘u’ lower-case? Its case sensitive and I gave you the wrong case! Command should be navigator.userAgent


#7

To me, the latest brave beta browser shows only one link now.

I remember seeing two links in Brave browser as well. Looks like that is solved.

But my latest chrome canary showing 2 links for both beta and Dev.
Firefox seems fine. Shows only one link.

All these browsers are latest releases.

Thanks