Brave closes without user commanding a close event from the top right "X"


Description of the issue:
Brave closes unexpectedly, semi-randomly, without user clicking ‘X’ for close.

How can this issue be reproduced?
Open Brave. Open one or more tabs / websites, any website at all. Go to (with cursor) most any Brave action control item on the toolbar, like the Brave Shields, or the Extensions ‘white puzzle piece’ at the far right side of the toolbar and then click. Brave then instantly closes. This can also happen after clicking open the settings ‘hamburger’ but not until you click onto something (anything) inside of the drop down menu. After you reopen Brave and relaunch the closed tabs this may not happen for few minutes when you repeat any action described above, but it will happen again after a random short passage of time. This started a few days ago.

Expected result:
Brave does not close without a user command to close.

Brave Version 1.38.109 Chromium: 101.0.4951.41 (Official Build) (64-bit)

Additional Information:
I have cleared all Brave cache.
Windows 10 LTSC 1809 (OS Build 17763.2867)
Intel Core i5-10400 CPU @ 2.90GHz
16 GB RAM, UHD Graphics 630

Is this board dead, or I am being ignored? I don’t really care which it is, I’d just like to know… :slight_smile:

Hi

@AshLee

Open New Private Window and test, if the problem persists disable extensions one by one to try to find the one that may cause the problem.

I first noticed this behavior in Private Window.
It also happens in Regular Window. It also happens in both Windows, with All extensions disabled. So, now what?

@AshLee

  1. Open brave://settings/system and check if Continue running background apps when Brave is closed and Use hardware acceleration when available are disabled

  2. Open task manager and send a screenshot of brave processes as below.

“Continue running background apps when Brave is closed” - I had this disabled.

“Use hardware acceleration when available are disabled” - This was enabled, I have disabled it and relaunched…I will test for a bit and then report back, later. (I have to go out for a while now. Thanks for the detailed advice!)

OK then, I’ve successful acquired my Five Guys Burgers & Fries. (I refuse to pay for delivery.)

I will now enable my extensions, one by one, testing as I cycle through them. If you don’t hear back from me on this, that means disabling hardware acceleration fixed the problem. Tanks again!

P.S. I assumed I had already disabled hardware acceleration, doing so is part of my Brave setup routine. That’s why I didn’t think to check on it’s status. Must have overlooked this one setting when I did a clean install of Windoze recently, lol at me.

“When you assume, you make an ass out of u and me.” - Oscar Wilde -

No matter what I do, or how I do it, Brave keeps crashing when the Shields icon, Extension icons, and almost anything inside of the Hamburger drop down menu is clicked. It always crashes when the Shields icon is clicked. Crashes about 60% to 70% of the time when the other places I describe above are clicked. I can’t / won’t spend more of my time trouble shooting this problem. I don’t support or use Win 11, so I’ll never know if this affects that version of Windows.

I only use and support Win 10 LTSC. I also make security tweaks and turn off three Windows Apps, maybe it could be buried somewhere in one of those changes on my end. But I have not done anything different this week from what I’ve been doing for years. That leads me wonder why this has suddenly started happening. So as I am type this message, I am now thinking it’s much more likely that it’s something in the latest update to Brave that is causing this behavior.

BTW the only extension I can’t disable completely is ‘Extension: Brave.’ I can kill it in Brave-Task-Man, but it comes right back. I also disabled everything under Brave Shields, no help. This makes Brave way too unstable for me to continue using myself. Or recommending to / keep supporting for my end users that opt continue to use Brave…It’s been great while it lasted, but sadly I / We (those that will listen to me, lol) must abandon Brave Browser now, after being loyal Brave users for years. I just can’t deal with Brave anymore due to this major problem. It’s back to Firefox for me/us :frowning:

I would have included two more screen shots here, but I keep getting this: “Sorry, there was an error uploading that file. Please try again.”

@AshLee ,

Try:

Start Brave Browser from the command line; with errors output to a Desktop text file, “brave_console_out.txt”.

The command is in 4 parts:

Part 1 is the path to the Brave executable (brave.exe)

Part 2 is the flag (--incognito)

Part 3 directs error output (2>) to

Part 4 a file on your Desktop (brave_console_out.txt)

NOTE that the location of opening and closing, plain/simple (not curly/smart) double-quote marks is important, in the following, lengthy command:

64 architecture

"C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe" --incognito 2> %USERPROFILE%\Desktop\brave_console_out.txt

Brave Browser will start and open a New Private Window (because: --incognito flag).

Additional flags to use, for testing; choose any single, or combo, with/without the --incognito flag:

--crash-on-failure
--disable-extensions
--disable-gpu
--enable-leak-detection

If Brave Browser keeps running . . .

In a Brave Browser > New Window, go to: brave://settings/cookies

Disable: Clear cookies and site data when you close all windows

Next, go to: brave://settings/clearBrowserData . . . and select the Clear browsing data > Basic tab.

Enable all 3 selections and click the Clear data button – BUT NOTE: the Clear cookies and other site data selection (when Enabled) will sign you out of most websites.

Return to: brave://settings/clearBrowserData

For the Clear browsing data > On Exit tab:

  • Disable: Passwords and other sign-in data
  • Disable: Site and Shields Settings

Click on the Save button.

In a Brave Browser > New Window, go to: brave://net-internals/#dns

and click on Clear host cache

Next, go to: brave://net-internals/#sockets

and click on both (in succession):

  • Close idle sockets
  • Flush socket pools

Exit/Quit everything and restart your computer.

In a Brave Browser > New Window - go to: brave://settings/security

Disable: Use secure DNS

And maybe . . . in a Brave Browser > New Window, go to: brave://settings/?search=Continue+where+you+left+off

And adjust the settings to about:blank as shown;

If you have Brave Browser to be the default Browser, choose a different Internet browser for that.

IOW, take steps to get Brave Browser free and clear from as many burdens as you can.

Thank you, 289wk.

I have archived this detailed Brave Browser ‘debug’ checklist.
If / when I take a look at this problem again, I will use your
checklist as the starting point.

Thanks again,
Ash.