Brave closes/crashes instantly when opening

Changing the brave.exe file name totally fixed it for me. Although when I changed the file name the shortcuts broke. Icons worked again once I created a new shortcut.

dude no way it worked!!! thanks so much!!!

Thanks this worked! Why’d it break to start, that’s so weird…

you should thank reddit user jamief64 :slight_smile:

What do i rename it to? or is it just any name?

Idk where brave.exe is.

Figured it out Noice, Thanks!

  1. Is there common hardware or software used? (post specs)
  2. There was talk that Asus TweakGPU causing issues, or maybe any other (MSI, EVGA?) GPU related software?
  3. Does running Brave.exe in admin mode make a difference?

+1 for this working! Renamed it to bravest.exe and I’m back in business. Thanks so much!

Do u still have your bat and everything?

I cleaned my windows drive with brave uninstalled everywhere else still unable to open.

EDIT: Scrolled down and changed the name im fine now.

Hey folks - based on the findings w/ renaming, I’m curious if folks here are gamers running a service like PunkBuster or GameGuard. These services will kill unallowed executables and some games will require you to run the service in order for you to play on ranked servers

If you’re not sure, you can check in Add/Remove programs (Windows + R; type appwiz.cpl and hit enter)

If you don’t a game service installed, one Redditor had a great suggestion. Look for and (if found) remove ASUS GPU Tweak. That might be scanning for executable names as they launch (which is why the rename bypasses).

2 Likes

This started happening on my sons computer around 12/15. I decided to reinstall Windows 11 and it immediately started happening as soon as Windows 11 was reinstalled and no apps had been installed yet. It turned out to be the content filter setting in his Microsoft account. This has been on for years without this happening.

I upi upgraded to windows 11 just to see if this issue gets resolved and it still doesn’t work.

Hi community, I have the same issue with Brave Beta, tried everything but nothing works. Any suggestions or recommendations.

Best, Stay safe

@JoseEscM,
You’re likely seeing the same issues as the users in this thread here:

The update that addressed this should have already been pushed – please try updating the browser and see if this resolves the issue. Note that if the browser closes before you have the chance to initiate an update, you can simply re-download and install the browser again (note that this will only apply the latest updates to the version you currently have installed).

So few weeks ago brave stopped working for me but i found a solution by renaming the brave exe. file but right now the same thing happened to me. its crashing now

So this happened again to me again so i went to change the exe files name and it looked like brave just created another exe file? It works after i changed the name of the new file but it seems a little odd to me

Changing name didn’t help me. Still closes instantly. So frustrating . It looks like this helped everyone but me.

@stansve5,
Can you please open your own thread here on Community and include all the information requested in the editor so we can have as much detail surrounding your situation as possible?