Brave closes/crashes instantly when opening

Chrome works but brave and firefox stopped working. Seems like firefox is also breaking for other users in this thread

I am having the issue on W11 with the 22000.376 co_release build (KB5008215 I think). I’m unsure if Firefox is having the same issue because I don’t have it installed but, edge and chrome work.

Edit: Firefox isn’t working two! They just kinda close because for a moment I can see the Firefox homepage and after I installed Firefox it opened for 3 seconds then closed.

Gif of me trying to open both of them:

Still investigating. If you create a new windows user (and login into that) and launch Brave/Firefox from that, does it change anything?

Also force close every application in the system tray.

Damm, at this point I would just clean install windows.
99% issue fixed
1% the issue persist(should we expect anything else from windows?)

Gonna try to avoid that.

a user on reddit said it fixed the issue by renaming the brave .exe file.

1 Like

Changing the brave.exe file name totally fixed it for me. Although when I changed the file name the shortcuts broke. Icons worked again once I created a new shortcut.

dude no way it worked!!! thanks so much!!!

Thanks this worked! Why’d it break to start, that’s so weird…

you should thank reddit user jamief64 :slight_smile:

What do i rename it to? or is it just any name?

Idk where brave.exe is.

Figured it out Noice, Thanks!

  1. Is there common hardware or software used? (post specs)
  2. There was talk that Asus TweakGPU causing issues, or maybe any other (MSI, EVGA?) GPU related software?
  3. Does running Brave.exe in admin mode make a difference?

+1 for this working! Renamed it to bravest.exe and I’m back in business. Thanks so much!

Do u still have your bat and everything?

I cleaned my windows drive with brave uninstalled everywhere else still unable to open.

EDIT: Scrolled down and changed the name im fine now.

Hey folks - based on the findings w/ renaming, I’m curious if folks here are gamers running a service like PunkBuster or GameGuard. These services will kill unallowed executables and some games will require you to run the service in order for you to play on ranked servers

If you’re not sure, you can check in Add/Remove programs (Windows + R; type appwiz.cpl and hit enter)

If you don’t a game service installed, one Redditor had a great suggestion. Look for and (if found) remove ASUS GPU Tweak. That might be scanning for executable names as they launch (which is why the rename bypasses).

2 Likes

This started happening on my sons computer around 12/15. I decided to reinstall Windows 11 and it immediately started happening as soon as Windows 11 was reinstalled and no apps had been installed yet. It turned out to be the content filter setting in his Microsoft account. This has been on for years without this happening.

I upi upgraded to windows 11 just to see if this issue gets resolved and it still doesn’t work.