Brave cannot open URLs containing umlauts (punny code problem)

Description of the issue: Brave cannot open URLs containing umlauts (punny code problem)

How can this issue be reproduced?

  1. Try to open http://www.kräuterhaus.de by directly typing it into the address bar.

Expected result: Website opens

Actual result: Website will not be opened

Brave Version( check About Brave): 1.19

Mobile Device details iPad 11 Pro and iPhone 11 Pro running iOS 13.6.1

Additional Information: Safari can open the URL without any problems. @Mattches @thommes

@Brave_user I’m able to repro this with the same Brave version on iOS and iPadOS 13.6.1. Instead of opening the website the search-engine comes up, showing the expected result on top of the list.

1 Like

@thommes Yes, exactly. And instead of search results the URL should be loaded. Android and Desktop work fine. Seems to be some kind of bug in iOS only.

@Brave_user to be exact, it’s some kind of bug in Brave on iOS. Safari works fine, so it’s not a bug in iOS.

1 Like

@Brave_user,
Going to take a look – if I can reproduce I will file an issue for the iOS team.

So it appears that this was intentionally removed from both Brave’s webkit implementation as well as Firefox’s:


So for security reasons, we do not support internationalized domain names at this point in time.

@Mattches Firefox for iOS works just fine with IDN. So IDN support might have been removed in the past but is working just fine in the recent release of Firefox for iOS.

Maybe Brave‘s devs might have forgotten to re-enable IDN support?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.