Brave browser will not allow access to my router

I get this message when trying to access my Asus router GUI:
router.asus.com refused to connect.
ERR_CONNECTION_REFUSED”

I can access my router on Microsoft Edge browser.

I changed all site settings to “allow” or “ask” and turn Firewall off. Still can’t acess the router GUI.

are you trying to access it locally or remotely? if local can you get there by ip?

Locally and my Windows 10 PC is connected to the router with an ethernet cable.
Again, I can access it with Edge browser.
thanks for reply

1 Like

did you try by ip? I ask because my previous router (a netgear) had a similar domain redirect that never worked right with brave, it worked fine by ip though.

I’ll try IP again

Best regards,

Tried using IP again - wierdly the GUI login to the router appears for a second and then the error page appears

there are a couple similar topics on the forum with some suggestions not sure if you had checked them.

Thanks for all the replies. I did try those and they don’t work.

I give up…

sry, hopefully someone else will come along with some ideas.

They didn’t fixed that and guess dont care to fix that so just use another browser cause they are busy with adding few new bugs and any other way to monetize their project. Best regards

turn off upgrade to https

That didn’t work but did get a screen that stated the site was not secure and I hit to go to it anyway and the GUI did flash for a second then went to this:
This site can’t be reached
router.asus.com refused to connect.
Try:

BUT, I note this on the address bar in that Brave is forcing/renaming to a secure address i.e. https which i think is the core problem…“https://router.asus.com/

Brave is adding the “s” to http:// i.e. making it https://that I type even though I verified
that the following Advanced setting was off:
“Upgrade navigations to HTTPS and warn you before loading sites that don’t support it”

yes it should work restart your browser maybe computer and try again


turn off always on secure connection