Brave Browser uses wrong GPU

I’m on a laptop with Nvidia Optimus, and Brave seems to be using GPU 1 for all tasks (the discrete GPU) rather than using GPU 0 (integrated GPU). This is despite using the NVidia control panel to select the integrated GPU instead of the discrete GPU. (By default, NVidia control panel wants to run Brave using the Integrated GPU.)

This can lead to unnecessary copying and GPU usage as GPU 1 isn’t connected to the laptop screen, so pixels need to be copied in and out of GPU memory for GPU 0 to display them.

How can this issue be reproduced?
Happens immediately on startup.

Expected result:
Should obey settings from the NVidia control panel and use the integrated GPU, or have an option to select which GPU to use.

Brave Version( check About Brave):
Version 1.9.80

Additional Information:
GPU: NVidia GTX 960M

2 Likes

I’m having the same issue. It started about a week ago. Brave won’t obey NVIDIA control panel settings. Any help would be appreciated.

I read that disabling hardware acceleration in Brave settings could stop the gpu from running when using Brave. I tried it on my laptop (Nvidia MX 150) and the gpu doesnt run when i launch Brave now. maybe you could give that a shot?

Can confirm this behavior on 1.10.97 (Chrome 83.1.10.97). Brave does not obey binding to GPU 0 if hardware acceleration is enabled.

Still happening on 1.11.97, is there any official bug report about this that can be followed?

This issue makes Brave not practically usuable for dual-GPU laptops, since it rapidly drains the battery on most systems and will result in permanently spinning fans.

Disabling hardware acceleration like @kyl3ria5 suggests is not an option since it will offload everything to the CPU instead, which will degrade performance and increase power consumption in another area.

I have the same problem. My PC has two GPU, one is inten iGPU and another is 940MX. The Brave Version is [Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)]

I compared performance check with Microsoft Edge, which uses iGPU, by playing a 1080p video on Youtube at the same time.
The Brave uses 10~30% CPU and 10~20% 940MX GPU and consumes VERY HIGH POWER ,
while Edge uses ~10% CPU and ~5% iGPU. It is a terrible result and consumes LOW POWER.

I will leave the Brave until this problem solved in the future.

I’m also experiencing this issue. Fans are always spinning due to brave using nvidia gpu instead of integrated intel one.

Turning off hardware acceleration makes brave lag horribly.

1 Like

It is september 2020, and the issue still exist

I found a working solution to this…
Turns out, there are two different control panels that will pick what GPU to use:

  • NVidia Control Panel
  • Windows Graphics Settings

To select integrated GPU for Brave:

  • Run “Settings”
  • Type in “Graphics Settings”
  • There will be an application list, click Browse…
  • Select Brave’s EXE file (usually “C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe”)
  • Click on the entry
  • Click Options button
  • Select “Power Saving” (for the integrated GPU), click Save

Now Brave will use the correct GPU.

2 Likes

This is the correct solution!!