Brave Browser unable to open shared Microsoft Office Online documents

Description of the issue:
I use Microsoft Office online documents for class (i.e., they are shared documents, used by various users, that open in the browser) through I have frequent trouble opening the documents; some will open after being repeatedly refreshed but some do not open. All will first open with a grey screen showing the angry document and the words “Connection was reset.” I toggle the “shields up” on and off to see if it will change the result, but it does not.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Log in to account through student email.
  2. Open any Microsoft Office online document–Excel, Word, etc.
  3. Repeatedly refresh the document; sometimes it loads, many times it does not.
  4. Toggle “shields up” and turn it off (or back on) to see if the result changes, it does not.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Viewing a shared Word or Excel document on the browser, in which I can make edits.

Reproduces how often:
Every time the documents are opened in Brave.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Home, Version 21H2.
Brave V. 1.36.116 Chromium - says it is up to date.

Additional Information:

Thank you for reaching out. Hard to test this without having an account/files to view of my own. Asking @fanboynz to take a look here as well.

Can you try doing this in a private browsing window and tell me whether or not you get the same results?

Thanks for responding! I actually have tried the private browser and it produces the same result–most documents will eventually open, but only after many attempts that produce the “reset” response. Worth mentioning: I have a school account that connects to Microsoft Online documents directly through Sharepoint–rather than through–and it also produces the same problem.

Just curious — can you try this with Shields = up but with the cookie control setting set to All cookies allowed and see if it makes a difference?

Is that the same as settings > shields > cookie blocking > disabled? I changed the setting from cookie blocking “only cross-site” to “disabled” and I think it may have improved. Now getting the “reset” error about half or less of refreshes instead of 80% or more.

I don’t have a account to test from, does the sharing issue occur on other sites?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.