Brave Browser suddenly running extremely slow

The Brave browser is suddenly almost unusable. The browser takes 20 seconds to open and switching tabs sometimes takes just as long. I verified my PC was not overloaded and other browsers work just fine. I am not aware of any changes made recently that could have caused the issue

I have:
Cleared cache / cookies
Verified CPU and Mem are both under 20% utilization even while brave is loading
cleared all tabs and started new windows
restarted PC

None have resolved the issue.

1 Like

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Can you also tell me if you have Brave Ads enabled at this time?

I’m having the same problem. It’s so bad that I’m moving my browsing back to FireFox. There’s no way to contact Brave for these problems. An error page loads before the destination page all the time - every time & there are many more pages that don’t work. This all began occurred with the new ads that pop up. The new ads are not bothersome but the slow loading & error screens are horrible. Fix it or lose users.

Which version of Brave are you seeing this on? I was recently experiencing some ‘lag’ type behavior that seems resolved in 1.30.89, possibly related.


Version 1.30.89 Chromium: 94.0.4606.81 (Official Build) (64-bit)

1 Like

OK, my question was more for the OP, I wonder if you guys may have 2 different issues.

@redfish what does the error page look like? Can you include the text, or a screenshot? Could it be this issue?


This message shows up on all new pages, after a while, it disappears & the page will load but sometimes the error message lingers quite some time - I could walk away & come back & if lucky the page I wanted to get to will finally load.

If you go to brave://settings/security?search=dns what do you have set for “Use secure DNS?”

Copied/paste:

Use secure DNS
Determines how to connect to websites over a secure connection

With your current service provider
Secure DNS may not be available all the time

OK. I suggest doing some testing with that setting turned completely Off, as well as with it On but set to some provider like Cloudflare or Quad9, and see if the behavior improves.

1 Like

Turning it off did not change anything but Quad9 seems to have worked. I’ll work with it & report any problems that might crop up. Hey - thanks for the help, very much appreciated!!

1 Like

Wanted to give a delayed update to make sure it worked.

This solution appears to have worked. Could be coincidental, but i havent had issues since making the change and restarting the computer.

Thank you

2 Likes

Same issue here - Brave got so slow that it was taking upwards of 30 seconds just to open a new tab, close an existing one, or even open up settings. Chrome, on the other hand, continued to zip right along. I have Brave on several machines here and they’re all in the same sync group, running all the same settings, all the same extensions, etc. The one machine was the only one having the poor performance problem, and that seemed to start suddenly just today, whereas yesterday it was running fine - and I’ve made no changes to the configuration on the one machine.
I disabled hardware acceleration on the one machine, and that helped tremendously.

I’ve read quite a few ‘hits’ where the suggested resolution to poor performance has been to disable acceleration. So, if this feature is so problematic and the first recommendation is almost always to disable it, why continue to provide it at all if you can’t make it work reliably?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.