Brave Browser stuck on a localhost url

A weird issue: When I want to navigate to “” (or localhost:8000), the browser changes the URL to “” – a link briefly used.

I simply want to navigate to plain old “” or “localhost:8000”.

No matter what I do–deleting “/catalog/”, deleting “catalog/”, or retyping “” or “localhost:8000” (with and without the trailing slash), the same URL re-appears–“” and of course that page is no longer available.

I deleted cache and that didn’t help. I went through the preferences section and couldn’t figure out what contributed to the issue.

I haven’t observed this issue with other URLS. Any suggestions?

Brave Version: 1.22.66

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.