Brave browser problem: Google sheets internal print function, instead of opening printer, downloads sheet automatically as pdf (bug)

#1

5.

  • B. See below screenshot of last step before Brave automatically downloads as a pdf, and doesn’t open print function.

  • C.

    • i. Windows 10
    • ii. Your Brave Version.
      Brave: 0.24.0
      V8: 6.9.427.23
      rev: f657f15bf7e0e0c50a2b854c6b05edb59bfc556c
      Muon: 8.1.6
      OS Release: 10.0.17134
      Update Channel: Release
      OS Architecture: x64
      OS Platform: Microsoft Windows
      Node.js: 7.9.0
      Brave Sync: v1.4.2
      libchromiumcontent: 69.0.3497.100
  • D. instructions of how you came across the issue.

    • i. I downloaded and installed Brave.! Logged into google drive to access existing google sheets (spreadsheets).
    • ii. opened google sheet document
      iii. used the print function on google sheets (not in brave browser) to print. this opens and allows me to select different parameters. Click “next” (see attachment) but instead of going to the printer selection, Brave downloads the document as a pdf. There is no option to print, select printer etc. Bug? Normally the browser says “sending to chrome print” and then you’ll get a window asking what the destination is, colour, etc.
      iv. FYI, printing using the Brave printer function, prints the whole page, including the bookmarks, toolbars, cell numbers and rows etc. The function we want to use is the internal Google Sheets print function.
      v. Tried this with a different google sheets document, had the same issue. Tried with Google chrome on same hardware, did not have an issue.
      vi. Was it something I did? Is anyone else having this issue?

0 Likes

#2

The bug continues (12 Mar 2019). In Google Docs the Print command gives the option of choosing the printer; in Google Sheets the Print command only generates a PDF.

Running Windows 10 on a PC.

0 Likes

#3

Hello!
Apologies to @stanno for not getting a response to this request when it was made.
@jnelson522,
Are you using Brave Muon or are you on the Chromium build? Asking because you should both know Muon is no longer supported, as we’ve moved to Brave Core Also, welcome to Community :slight_smile: :tada::tada:

Interestingly enough, this issue is still present in Core, so thanks for bringing it to our attention! I’ve logged it here for the team to address:

0 Likes

closed #4
0 Likes