Brave Browser Notifications - Keeps asking me when I don't want it

I am constantly getting this notification below asking me if I want notifications. It never remembers that I don’t want it. I say “Don’t Allow” ALL THE TIME. Logging in and out of different users should NOT be reactivating this since I click “Don’t Allow” when signed in to a different user. Doesn’t happen every time I log in but enough that it’s clearly not recognizing that I don’t want notifications.

“Brave Browser” Notifications
Notifications may include alerts, sounds, and icon badges.

Rewards are disabled, so it’s not that.

Hi and welcome to the community. :slightly_smiling_face:

Have you tried to adjust the settings at brave://settings/content/notifications? Just changing the default settings would probably work. Posted a screenshot of the various options below. Hope this helps! :slightly_smiling_face:

1 Like

Also, on which site are you facing this? Does it happen with all the sites?

1 Like

It’s the browser’s notification. Not any site. The browser keeps doing it and I’m trying to find the setting that disables it. I still keep getting the below notification when I open the browser.

“Brave Browser” Notifications
Notifications may include alerts, sounds, and icon badges.

Just a FYI, it’s hard to give you any advice when you don’t say any specifics. For example, what device are you using? It would be silly to tell you how to change things on Windows if you’re on Mac, Linux, Android, etc. So if you can try to cover that, it would be ideal.

Clicking on Don't Allow won’t necessarily be the resolution. You’ll need to go to your system’s menu and disable notifications for Brave there. With that done, you shouldn’t have any issues at all.

Hi,
I am using Mac Monterey. This is what I am seeing (see link). Where do I go from here?

https://drive.google.com/file/d/1RXsXlscv3-CaV65ZssRcLVlmbAJ-7w37/view?usp=sharing

I’m not saying you would do anything from that. Go to your system settings, your Mac settings.

On your Mac, choose Apple menu > System Preferences, then click Notifications & Focus .

Click Notifications, select an app or website on the left, then deselect Allow Notifications on the right.

You won’t receive notifications for it until you select Allow Notifications again.

So to to your System Preferences, click Notifications & Focus, go to Brave and make sure Allow Notifications is not selected. From then on, you’ll never have a notification from Brave again. At least you shouldn’t.

@ivanv Alternatively, you can leave “Sites can ask to send notifications” as the Default behavior at brave://settings/content/notifications. When the pop-up appears, just choose “forever” from the dropdown and then click block. This will add the site to “Not allowed to send notifications” in brave://settings/content/notifications.

Example:
image

image

image

I personally use this method. I do allow notifications for some sites which can vary by profile and I would prefer to use Brave settings rather than system settings to control my options. Just my preference and you may prefer to use system settings.

@Chocoholic Thanks but its not sites that I’m trying to avoid notifications from. It’s the browser itself that keeps popping up.

@Saoiray Yes, this is not selected. So why does it keep popping up? It should not.

@ivanv So, are you saying at brave://settings/content/notifications when Notifications Default behavior is set to Don't allow sites to send notifications and/or a site (Brave site or any other site) is added to Customized behaviors you are still getting notifications? Is this the issue or am I totally misunderstanding the issue?

image

image

@Chocoholic Isn’t it the computer, not the browser that keeps popping up with the notifications? Not inside the browser. see screenshot of top right of screen notification: https://drive.google.com/file/d/1VmkU298j1aqRUB4f5i6zNm-DGXebizFy/view?usp=sharing

Thanks for the image. It helps clarify. Just use the instructions provided by Saoiray and post an update: Turn off notifications for an app or website on Mac. Take care. :slightly_smiling_face:

It would seem that way. Can you share a screenshot of the notification settings you have in your Mac, particularly for Brave? Also, which version of Mac are you using?

Also, what happens if you click that banner? I’m almost wondering if you initially need to give Brave permission and then set it not to have notifications. I’m not entirely sure of your situation, when it’s coming up, etc. But if notifications are off and that’s still coming up, then it’s likely something silly.

I have the same issue. I absolutely don’t want notifications ever, either within the browser or on the Mac desktop, yet when Brave is updated to a new version I tend get a notification on the Mac desktop asking me to allow browser notifications, similar to the one in this screenshot from the original poster:

Here’s my settings:

1- Within Brave:

2- Mac settings:

Environment:

  • Brave Version 1.42.95 Chromium: 104.0.5112.81 (Official Build) (arm64)
  • MacOS Monterey 12.5 (21G72)

I also use a separate Mac for work, which is still on macOS Big Sur and Intel processor, and also experience the same issue, usually when there’s a new version of Brave.

Hope this helps. Thanks.

My screenshots are the same as @optimus . Everything is off. The options when hitting that notification from the mac I think says allow or don’t allow. I always click don’t allow.

@Mattches do you have any clues? I’m lost on this, especially since I don’t have a Mac.

I have the same issue, all mac book pro system notifications shut off, and all settings in brave are set to “never allow these F’s to notify me of a damn thing” and it still pops up. Simple fact, you all gave this guy a hard time, but it’s a real thing, it’s in brave browser, and you’re (brave) walking a fine line to eventually no one using this browser.

I mean I do get it, using your browser for free, and never paying attention to you what so ever is not a good model for you. LOL. I’ll probably just end up back on chrome though. The Brave community is 100% BS. Worst obsurd crap I’ve ever seen with those lame ‘rewards’ and what not. LOL

@ivanv,
Yeah I understand what’s happening but I’m not sure why. I’ve definitely seen this notification pop up before, but it should go away once dismissed. I’ll have to ask the team about this because I’m not sure what other possible reason it could have to send these or now it bypasses every setting you have configured to stop that from happening.

To clarify, does this happen every update? Like, is that the frequency in which you see these notifications? Or does it happen more frequently? If so, is there any behavior that results in the notification showing up or is it random?

@Mattches It happens when I sign in to this particular user for the most part. I think it might happen at seemingly random times too. It has started happening on my other sign in account too recently but normally doesn’t.