Brave Browser loses internet connection after opening F12 tools

Brave browser tab loses internet connection after devtools is opened on that tab. This issue only affects the Brave browser in the tab the devtools are opened in. My other browsers (Firefox, etc) and other tabs in the Brave browser do not lose their network connection when this happens.

How can this issue be reproduced?

  1. Ensure you have internet connection
  2. Navigate to e.g. on one tab and on other
  3. Select one of the tabbed windows and press F12 (devtools window opens)
  4. Reload the page under that same tab
  5. Notice that Brave browser gives the error “ERR_INTERNET_DISCONNECTED”

Expected result:
Expecting that it would be possible to reload page after opening devtools.

Brave Version( check About Brave):
Version 1.43.93 Chromium: 105.0.5195.127

Additional Information:
Running on Windows 10 (64-bit)

I just tested on Windows 10 Pro, didn’t seem to happen. I refreshed page by hitting Refresh button icon on Brave, hit F5, and also tried Ctrl R. I refreshed on both tabs and even on different window. Opened dev tools (F12) on just one and refreshed. Then went to other tab, refreshed. Opened dev tools on both, refreshed. Closed on both, refreshed. In all cases, everything worked fine.

The way I could replicate though was if you’ve somehow changed the dev tool to assume you were offline. When you hit F12 to open it, you should have a Network tab. To the right of the box that says Disable Cache there will be a dropdown box. In it, you can set to Offline, Slow 3G, Fast 3G, No Throttling, or Custom. If I switch it to Offline then whenever I open Dev Tools and refresh, it will give me the ERR_INTERNET_DISCONNECTED message, because Dev Tools is telling it I’m offline.

Sorry for the long explanation, but could you check that?

1 Like

Thank you @Saoiray. It was exactly that dropdown box.

1 Like

Go to network tab and see if you applied any network speed limit or offline. And remove network limits…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.