Brave Browser integration with uphold on mobile phone

No, I have 2 phones with Brave Brawser and Uphold app and this is the first time i have that kind of problem.

Ok. I recently had the same issue where my android phone was disconnected. It took me several tries and a few hours to reconnect to uphold. Wait a couple hours and try again. If it persists, come back and let us know.

…than i proceed with the login…

at this point i try to reauthorize but nothing. It’s 3 weeks i have this problem.

In the pc i have no problems, only on the 2 phones.

Try turning off brave shields and any vpn if you have one and try again. If you are getting any sign in verification from uphold, make sure you are clicking the link in the email on the device you are trying to authorize.

Nothing. I also spoke with the uphold support team about the problem, they re-direct me here.

Sorry for my bad English.

Go here~ brave://rewards-internals
Navigate to “Event Logs”
Scroll through and see if anything says “Device Limit Reached”.

I don’t find “device limit reached”.

What country are you in?

If you are using android, does it pass the safetynet check?

1 Like

I am resident in Italy but i am Portughese.

Hey @Zeruiu

You must to uninstall Uphold app

And try to reconect again.

At this point Brave Broser open the Upbold web page and you log-in.

Hi cmam. I tried but the problem persists. Tnx

I tried SafetyNet test and Checker but the problem is still there.

Ok. Time to bring in the big guns. @Mattches @steeven
Maybe they can help.

hahaha, ok, i’m gonna take a look. Thank you.

I think the issue has to do with the Uphold app.

Please follow these instructions exactly:

  1. Uninstall the Uphold app from your phone
  2. Open Brave and visit
  3. Login to your Uphold account
  4. Open the Shields panel after logging in (lion icon in the address bar) and change the cookies setting to All cookies allowed
  5. Now tap the BAT icon and then Verify wallet
  6. Reauthorize your account using the browser

I solve the problem with the point 1,2,3,5,6. The point 4 it’s not necessary. Thanks and sorry for my bad English.


@Zeruiu yes that worked! Thank you so much!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.