Brave Browser hiding all of my other applications

Brave Browser is opening and working well, but whenever I try to open another application Brave Browser hides that application and only allows me to see Brave. It has gotten irritating over the past 2 weeks. Thank you.

Brave Browser number: Version 1.38.115 Chromium: 101.0.4951.64
MacOs number: 11.6.5

Hi

Open brave, then open a private window by holding CTRL+SHIFT+N. Open other apps.

Result?

Thank you for responding CerealLover. I tried that and Brave still hid all my other applications. But thank you!

Hello @siwelwel

are you sure you not openening brave in full screen ?

could you share screen shoot of what you see or mean by hiding other applications ?

Hi

Do you have "Microsoft PowerToys Always on top " installed or similar app?

For Windows, Try pushing These buttons: WINDOWS+TAB

@CerealLover I have a MacBook Air. I don’t have Microsoft PowerToys Always on top installed or a similar app.

@siwelwel

Please edit your Original Post (“OP”) content, to include:

  • Brave Browser version numbers
  • Mac OS version numbers

And, what (if any) extensions do you have installed on Brave Browser? In a Brave Browser > New Window, go to:

  • brave://settings/extensions
  • brave://extensions

And, have you set Brave Browser to be the default Internet browser on your Mac?

And, in your Mac’s System Preferences, have you set Brave Browser to launch when you start up your Mac?

Also, as @justsomeone1 asked you:

Brave Browser window - is it full screen?

1 Like

@289wk
Hi,

  1. Brave Browser is not in full screen.
  2. I have no extensions installed on Brave.
  3. I have set Brave Browser to the default internet browser on my Mac.

@siwelwel

Check your Hide Others setting:

Screen Shot 2022-05-14 at 7.10.31 PM

1 Like

@289wk

My Hide Others setting is exactly as yours is.

3A3A97AA-AEFD-462D-9352-B53005F19AEA_4_5005_c

@siwelwel

With only 2 applications running, one of them being Brave Browser, test the two selections.

With only 2 applications running, BOTH NOT being Brave Browser, test the two selections.

Consider what may be happening, because of:

1 Like

@289wk
Hi,
I have already tested those. When Brave is running Brave hides all other applications, but when Brave is quited all other applications can run. Also when I try to switch desktops it immediately switches back to my Brave window.
Thank you.

@siwelwel

When Brave Browser is not set to be the default?

And, did you check to see, if somehow, Brave Browser is set to launch when you Start your Mac?

Tests, if you are willing. I am prepared to do such testing, but many Mac users are not accustomed. OK, either way.

Problem might be in one (sometimes, both) of the following .plist files:

/Users/username/Library/Preferences/com.apple.dock.plist

/Users/username/Library/Preferences/com.apple.finder.plist

Take a screenshot of your entire Mac Desktop.

Take a screenshot of your entire Dock.

You’ll need those screenshots, to guide your restoring some of the Finder settings and / or the Dock settings.

Set Safari to be the Default Internet browser.

Quit all applications.

Locate and drag one of the .plist files to the Desktop. (Try the Dock file, first.)

Restart the Mac.

Start Brave Browser. Start some other application. Does issue exist?

Repeat steps, for the other .plist file.

1 Like

@289wk
Brave Browser is set to default. Also Brave Browser is set to launch when I start my Mac.

It has fixed!! I talked to Apple Services and what they told me was to restart my computer and when it goes to the apple icon hold down shift and when it comes to the login page, let go and login and try again! It worked for me! Thank you guys for helping me as best as you can!

2 Likes

@siwelwel

“Browser is set to launch when I start my Mac.”

https://support.apple.com/guide/mac-help/start-up-your-mac-in-safe-mode-mh21245/mac

Starting up your Mac in safe mode can help you determine whether issues you’re experiencing are caused by software that loads as your Mac starts up.

Good work - you kept after the steps to troubleshoot the issue. Thank you.

1 Like

@289wk
Hi,
The apple support person told me to start up in safe as well.

Thank you!

1 Like

@justsomeone1 No problem!

1 Like