Brave Browser Helper (Renderer) uses 100% CPU when ad blocking enabled

Description of the issue:
Brave Browser Helper (Renderer) runs at 100% CPU on www.logos.com. Switching Shields to “Allow All Trackers and Ads” fixes the issue.

**Steps to Reproduce (add as many as necessary): **

  1. Visit www.logos.com

Actual Result (gifs and screenshots are welcome!):
Brave Browser Helper (Renderer) uses 100% of CPU.

Expected result:
Should be able to block trackers and ads without using 100% of the CPU.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
macOS 10.15.6
Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)]

Additional Information:

Hello @krd

could you try to disable all extension and also hardware acceleration

hope that help and have a nice day :slight_smile:

I disable both of those with no success. I manage to isolate the issue to the ad blocking. Once that was deactivated the CPU returned to normal. It would seem there is an issue with the ad blocking.

i do not know let me ask for one of the team @Mattches to help you

hope it get fixed and have a nice day both of you :slight_smile:

@justsomeone1,
cc @fanboynz on this – would you mind taking a look and see whats causing the uptick?

Hey @krd have logged a bug report, https://github.com/brave/brave-browser/issues/11505

No ETA, but we have an idea what is causing it.

1 Like