Brave Browser Helper (Renderer) - 100% of CPU

brave browser helper (Renderer) is almost constantly using more than 90% of the cpu, i was on macOS big surf ver 11.5 and upgraded to 11.6 yesterday to see if it would help but it did not, i’ve been having this problem for 2 days now, i am on version 1.30.87 of brave.

i see this is not a new problem is a shame i really liked the brave browser but unfortunately i’m going to go back to safari.

I respect your decision to change, but I installed a different version of Brave and so I could know if my machine works fine. I recommend Brave Nightly :money_mouth_face:

1 Like

Thanks for letting me know i’ll see how brave nightly works.

1 Like

For anyone encountering this issue, the first things to check (and report back here) are:

  • Does disabling Hardware Acceleration have any effect?
  • Does creating a new profile and/or disabling any installed extensions improve performance?
  • Does disabling Brave Ads (toggle in Settings --> Brave Rewards) improve performance?

I disable hardware acceleration since the problem started but there was no difference and I never had any extensions downloaded, i just disable brave rewords and it change nothing.

I wouldn’t really recommend you Brave Nightly, as it has bugs and it is for professional developers, while also having bugs which may delete your browsing data, bookmarks, etc.

And I yet still have this problem, when will the issue be fixed? I wanna use Brave, use the ad-blocker, use Brave Rewards and install extensions so I can have a great browsing experience! :unamused:

@Kristian it might be system problem rather than the browser it self.

Hey Guys -
I too am having the issue w/Brave browser helper (renderer and regular, it varies).
I’ve done everything everyone else has tried, and it still persists. I do have to say that sometimes, again, sometimes…when i goto activity monitor it all of a sudden seems to stop and drops considerably. It’s just very weird and frustrating. FYI I’m using latest mac os and latest brave on a 2015 13" retina mbp.
neway…i really like brave and switched from chrome couple yrs ago…I do NOT wanna have to go back to chrome. There’s gotta be a reason…cmon devs, release an update that addresses the problem…please!

It is exactly what happened with my machine and I thank you for sharing this with us. in my particular case (Dell I7 win 10 pro 64), it crashed to the point of being a very unpleasant situation. I fix it a bit by turning off the Hardware Acceleration option. only once in a while, it stays a few minutes at 100% of the cpu and I can’t use the machine. I have faith and hope that this great problem will be solved and that it does not take away the great advantages that this browser has :money_mouth_face:

hey…
no worries, and ur welcome. it’s just insanely frustrating when SO many people are experiencing the same thing basically and it’s NOT ADDRESSED!!!
SO…It’s clearly not EVERY1s computer…it’s BRAVE. Which I love and left Chrome for…(sounds like a bad romance novel, lol)

But…if not addressed…what is 1 to do?

1 Like

Well look, I can only tell you that we must all continue to wait for that enormous problem to be solved. I know there is a team of professionals working hard to solve it. They are already doing the tests with the pop-up ads and it looks interesting. we just have to wait :money_mouth_face:

No, it is not a system problem at all. My computer is 3-4 months old.

1 Like

sigh…it is NOT a system problem

1 Like