Brave Browser Helper (Renderer) - 100% of CPU

Lastpass works great for a few months.

I then start hearing the fan caused by high cpu.

I delete lastpass, then reinstall, everything is fine for a few more months.

Hope that’s clear.

Just had to do the delete and reinstall today. That’s what brought me to this topic

@afotherg,
I wonder if its the cache data from LastPass graudally collecting/getting stuck, subsequently casuing the cpu to struggle with the clump of data. I’ll dig into this a little more on my end – good sleuthing on your part :slight_smile:

This I think is a general issue, not particular to Brave Browser. I experienced it just now, so I stated my Chrome browser and immediately noticed the same issue there.

The fact is my mac is running slow right now (very slow) and the reason for the renderer or helper is to kick in and render the page, it is some kind of mechanism. The real issue is, the computer being slow, which could be it is busy doing something or updating index, I am attaching my screenshot it. I will probably leave the laptop running for the night and hopefully all the updates should be done the next day.

Screen Shot 2020-06-30 at 11.21.14 PM

Also got the same issue. Brave using 311MB of memory while just having 3 opened tabs. Brave is updated to the newest version.

Unfortunately, I have the same issue. Don’t you guys have a solution? It makes my computer slower and drains a lot energy. It’s kinda working on Blender 3d.

MacBook Pro (16-inch, 2019)
2,6 GHz 6-Core Intel Core i7
16 GB 2667 MHz DDR4

1 Like

1.12.114 is eating my RAM. There was no problem until yesterday.

MacBook Pro 15-inch 2014, 2.2 GHz i7, 16 GB RAM.

Just one tab is utilizing this.

2 Likes

I am facing the same issue since yesterday. There are only 10 tabs open in my browser and single window. My Brave screen turns gray when this usage spikes to 101% and i have to kill the process to get back my normal screen.
I am using MackbookPro 13-inch,2017 with 8GB Ram. Brave version 1.12.114

1 Like

Hi @zachariasmanuel - do you have the Grammerly extension installed? There is a known issue with a fix on the way. CC @Mattches

I was also facing the same problem. I am not sure of the actual issue but something that worked for me was clearing cache data and cookies from the beginning. I cleared all of them and no-longer seeing the high CPU issue. I will update if the issue comes back.

Disabled Grammarly and solved the issue. Thanks @steeven. CC @Mattches

1 Like

Was having the exact same CPU issue. Just disabled grammarly and seems to have solved the issue. When should we expect a fix? How will we know when it’s okay turn it back on?

Just wanted to put a +1 for the issue being caused by the Grammarly plugin. I removed it and immediately the GPU and Helper processes went back to normal. Appreciate the help everyone!

1 Like

Well, I don’t have Grammerly installed, nor am I using Hardware Acceleration, yet the browser is using 2 GBs and GPU Process is eating up 5.2 GBs of RAM, and I’m not even playing any videos, and just refreshed Brave. Why so much RAM eaten up? Oh, and just between those two, it’s CPU usage is fluctuating between 22% and 60% !!