Brave Browser Helper (Renderer) - 100% of CPU

@afotherg,
Wait – so you’re seeing that if you do not run the LastPass browser extension, you get better performance results?

Lastpass works great for a few months.

I then start hearing the fan caused by high cpu.

I delete lastpass, then reinstall, everything is fine for a few more months.

Hope that’s clear.

Just had to do the delete and reinstall today. That’s what brought me to this topic

@afotherg,
I wonder if its the cache data from LastPass graudally collecting/getting stuck, subsequently casuing the cpu to struggle with the clump of data. I’ll dig into this a little more on my end – good sleuthing on your part :slight_smile:

This I think is a general issue, not particular to Brave Browser. I experienced it just now, so I stated my Chrome browser and immediately noticed the same issue there.

The fact is my mac is running slow right now (very slow) and the reason for the renderer or helper is to kick in and render the page, it is some kind of mechanism. The real issue is, the computer being slow, which could be it is busy doing something or updating index, I am attaching my screenshot it. I will probably leave the laptop running for the night and hopefully all the updates should be done the next day.

Screen Shot 2020-06-30 at 11.21.14 PM

Also got the same issue. Brave using 311MB of memory while just having 3 opened tabs. Brave is updated to the newest version.

Unfortunately, I have the same issue. Don’t you guys have a solution? It makes my computer slower and drains a lot energy. It’s kinda working on Blender 3d.

MacBook Pro (16-inch, 2019)
2,6 GHz 6-Core Intel Core i7
16 GB 2667 MHz DDR4

1 Like

1.12.114 is eating my RAM. There was no problem until yesterday.

MacBook Pro 15-inch 2014, 2.2 GHz i7, 16 GB RAM.

Just one tab is utilizing this.

2 Likes

I am facing the same issue since yesterday. There are only 10 tabs open in my browser and single window. My Brave screen turns gray when this usage spikes to 101% and i have to kill the process to get back my normal screen.
I am using MackbookPro 13-inch,2017 with 8GB Ram. Brave version 1.12.114

1 Like

Hi @zachariasmanuel - do you have the Grammerly extension installed? There is a known issue with a fix on the way. CC @Mattches

I was also facing the same problem. I am not sure of the actual issue but something that worked for me was clearing cache data and cookies from the beginning. I cleared all of them and no-longer seeing the high CPU issue. I will update if the issue comes back.

Disabled Grammarly and solved the issue. Thanks @steeven. CC @Mattches

1 Like

Was having the exact same CPU issue. Just disabled grammarly and seems to have solved the issue. When should we expect a fix? How will we know when it’s okay turn it back on?

Just wanted to put a +1 for the issue being caused by the Grammarly plugin. I removed it and immediately the GPU and Helper processes went back to normal. Appreciate the help everyone!

1 Like

Well, I don’t have Grammerly installed, nor am I using Hardware Acceleration, yet the browser is using 2 GBs and GPU Process is eating up 5.2 GBs of RAM, and I’m not even playing any videos, and just refreshed Brave. Why so much RAM eaten up? Oh, and just between those two, it’s CPU usage is fluctuating between 22% and 60% !!

Just want to report that I too am experiencing this issue when on various sites. I have a macbook pro 2015 (macOS Catalina).

I do not and never have had the Grammarly extension installed. Definitely hoping a solution is found to resolve this issue!

Thanks!

Same problems as above. Late 2013 Macbook Pro, 16 GB, OSX 10.13.3 2.6 GHz i7.

The problem is a runaway renderer with HWA off/on…makes no difference. Other apps running include PCcharm, sometimes serving a local nginx server, sometimes not. It does not appear on access to pages on my Apache/FreeBSD based servers, but does appear nearly always when launching a page from Foxnews to an article. The article will be excessively slow to load.

If I open the sub-article in a new screen/tab it loads promptly and the Renderer runaway does not occur as often. I’ve seen this occasionally with Marketwatch.com as well. FN support suggests it is because I don’t let spyware ads look at my computer. Even if so, there should be some means of detecting and rejecting/bypassing this ill-mannered behavior on the part of servers.

Same issue, Linux mint 20, Why is your audio renderer eating 18 gig? give me a break.

I’m getting close to abandoning Brave. The Renderer issue is making it virtually unusable. Brave constantly eats up most of my CPU. Why hasn’t this problem been addressed after months of complaints?

Actually - Brave is now sucking up a lot of energy. The biggest user of energy in the Energy Impact activity monitory. What is up with that?

And the energy usage is all related to Renderer.