Brave Browser Helper (Renderer) - 100% of CPU

There are ongoing reports of the same thing and no response, investigation beyond suggesting disabling plugins or hardware acceleration that don’t work. How does any further investigation get done. I’m a big Brave fan but bordering on having to stop using for the time being b/c can’t afford ensuring Mac is always plugged in or having it run down so quickly b/c constantly pegged.

1 Like

Another one, one guy reports the same problem another reports a false connection (a different app) but no response. However there is a clear pattern here coming from MacOS

For myself I know before around Jan/Feb machine was not having any trouble with Brave and I’ve been using it since well before 1.0 Haven’t added new plugins. Had been on Catalina a while with no issues. No obvious changes to environment, pegging is clearly in Brave Browser Helper app. Would be happy to do what I can to help profile it somehow.

I’ve also tried creating a new profile as mentioned above and launching to that the CPU still nearly pegs constantly >90% and stays that way, even with no history, no browsing to any site. HW acceleration still off. @Mattches

So no resolution to this? Same thing happening here. The computer sounds like B-52 at takeoff and it is driving me insane. Too bad, since it is the best browser. Hopefully a solution is found, or will be forced to stop using it.

Same issues here. Annoying as I wrote a big message then soon as I pressed upload image it deleted all my text in this post!

Version 1.7.60 Chromium: 80.0.3987.132 (Official Build) dev (64-bit)
MacOS Catalina: 10.15.3 (19D76)
MacBook Pro (15-inch, 2018) - 2.2 GHz 6-Core Intel Core i7 - 16 GB 2400 MHz DDR4 - Intel UHD Graphics 630 1536 MB

I’ve tried all the suggestions, one observation I’ve see is minimising the browser will bring it down slightly but then back to high CPU and temp.

Has anyone updated to the latest Dev version today? I’m not seeing any problems so far after 10mins. I’ll wait and see for longer. Version 1.7.63 Chromium: 80.0.3987.132 (Official Build) dev (64-bit)

Solution:

Downloading the Brave Beta Browser works for me, everything is back to normal in terms of CPU usage vs. Brave Browser Helper (Renderer): https://brave.com/download-beta/

It doesn’t fix the problem but guess it’s an intermediate solution for the time being. Hope this helps!

Same issue here. 2019 Macbook pro, Mac OS X 10.14.6 (18G95), 16 Gb memory and 2.6 GHz Intel Core i7, so it should not be draggy. Brave is latest Version 1.5.113 Chromium: 80.0.3987.149

I downloaded the Beta version, but can’t get it to even open - crashes.

Any suggestions for getting the Beta to run?

Anyone in this thread,
Thank you for reporting – can you please see the pinned post we made earlier today and follow the instructions given so that we can get as much data on the issue in one place as possible:

I also (separately) reported this 2 months ago: Brave Browser Helper running 99% CPU

I have not figured out how to solve this and have unfortunately stopped using Brave since then.

I’m having the same problem. It opens 22 of them at a time (I counted) and uses crazy amounts of CPU and memory. Seems to happen anytime I’m playing a video, and anytime a new page is loading. I turned off the Hardware Acceleration but it made no difference. I tried switching off all the extensions, including the built-in ones, but that made no difference either, besides which, chrome can handle them just fine.
MacBook Pro (13-inch, Late 2011) with OSX 10.13.6


I just switched to brave because of all the articles and reviews saying it was lightweight, but this is awful. I’m going back to chrome. I do not need this headache right now, I need to use resource heavy CAD software on a virtual machine in parallels at the same time, this is making it unusable and disrupting my entire day and workflow.

I’m having a similar problem, but not so much with CPU usage, but that Brave Browser Helper (GPU) app is using 3.6 GB of RAM! I tried closing and rebooting Brave, but the RAM usage remains at that level, even after refreshing. Also, every time I open a new tab, I have to sit and wait, staring at a totally blank page, until the top sites finally load, (I only have about five)… then I can put in the url or search. It will sit there for anywhere from 10 to 20 seconds, which is ridiculous… I’ve never, ever seen a browser act like that…

@HannahRosen,
I can see right there that Brave is actually using less CPU than the activity monitor itself although I do believe that you see spikes as you’re describing.

You said you tried disabling HWA and extensions – can you try browsing/viewing video content on a new profile (Menu --> Create new profile)? I’m wondering if there is something specific to the data you have in your profile that is clogging things up.

@StevenCee,
You can try disabling Hardware Acceleration and see if that helps, but I actually would suggest the same thing I suggested @HannahRosen – try creating a new profile and see how it performs. It’s more than likely you have some “bad data” stored in cache and it’s causing the slow down. Testing against a new profile with no data, extensions, history etc will rule out whether or not the issue is related to Brave itself or some data contained within it.

Will creating a new profile delete my current one, or just add an additional one? As for “bad data stored in cache” I constantly clear my cache, and I have hardware acceleration off… I wonder why it’s even there, since for every browser, that’s often the first advice given when people have problems, disable it.
And it’s odd that none of my open tabs are using much RAM or CPU, but for the browser: 1.6 GB RAM 19.5% CPU
and the GPU Process 4.0 GB RAM 16% CPU
Also, total RAM used by Brave at this time is 17.3 GB !!

@StevenCee,
There’s certainly something wrong with your situation – on my end, I’m also on macOS and at this time, I’m running 4 instances of Brave (Nightly, Dev, Beta, Release) with multiple tabs each, in parallel, along with several other applications on my Macbook, and I’m seeing the following:

And no, creating a new profile will not delete the old one.

I’m not sure what your screenshot is supposed be showing me. It just shows your computer’s total memory, not how much of it is Brave, or the GPU helper, etc. Oh, I see, with several versions of Brave, you can still use it and be under 7GB of RAM… Yeah, something definitely is wrong with my end, as just a few days ago, I was noticing how little RAM it was using. Now it’s blowing up… I guess I’ll try the new profile, and see. However, if it works ok, then that won’t be of that much help, for I won’t know if it’s an extension, one of the windows I have open, or who knows what else? Not sure how I would begin to narrow it down. Would downloading and reinstalling it again, somehow change anything, for the better?

@StevenCee,
Downloading and reinstalling very well may help but it’s far more work than running this easy test (creating a new profile temporarily). The reason I like suggesting this test is because it’s not just simple but it will point us in the right direction – let me know what you find out.

I understand it’s simple to just use a new profile, my question is where do I go from there? If it’s ok with the new one, what would that mean, or if it still doesn’t work well, then what would I do? You’re only telling me to do a reading, not what to do once I know whether it works or not with a new profile.

@StevenCee,
If it works with a new profile, then something contained within your “normal” browsing profile is causing the conflict.

If you create a new profile and are still seeing the same GPU resources used, we’re likely looking at an issue/conflict between your machine (and its components) and Brave itself. Which means we’re looking at a much broader potential cause for the behavior – this may require reinstalling or testing another Brave build.

If you create a new profile and it works without any issues, then we know the problem lies within the profile and data, rather than the machine and browser. This might mean trying to deleting all profile data (using the Clear browsing data option in Settings --> History), or digging into the individual sites that.

1 Like

I have had the problem many times.

In my case, I solve by going to Extensions, and removing the Lastpass extension.

I then reinstall Lastpass.

Problem solved for me for a few months. It’s a hassle, but far better than the racket the fan makes.