Brave Browser having usage issues with multiple websites

Description of the issue:
I have trouble getting certain retail websites to work (for example Ugg, Gap, Athleta, Sundance, Steve Madden etc.). When I connect to the site, it launches, but I cannot click on any of the content or I can browse content but not add items to my cart. I often get a web page is unresponsive message.
This is happening on multiple computers. The websites work fine in Chrome and Firefox. I have tons of other sites that work just fine.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Happens every time I access websites. It is not all websites, just a few.

Actual Result (gifs and screenshots are welcome!):
It is hard to capture the problem as it is lack of ability to “browse” and actually use website.

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):
I have MacOS High Sierra 10.13.6. This is an old machine:)
Brave Version: 1.45.113

Additional Information:
I have cleared all cache, cookies and data and resinstalled Brave
I have turned off scripting
I have installed Brave on a Windows 11 workstation and the problem still exists

so in summary the problem exists on 3 different computers (MAC and Windows) and there are no issues with Chrome & Firefox with these sites on all of the computers.

1 Like

@Jarc-1107 @Alice2095 @Kevin_cc please help! Thanks.

Hello there @rharrell4422 Could you please try opening your main profile in private mode to see if the pages load? If they do load, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.